aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-04-08 10:06:36 +0200
committerBart Ribbers <bribbers@disroot.org>2021-04-09 09:31:03 +0200
commitb5cd458a488cc6694c5879a2566d700122c060e9 (patch)
tree7a83fdca87681335f91de8bf5aa4e1b63a9a8259
parent47334b0183d4c8e9781cf9535cf6f3f39baa8606 (diff)
community/qt5-qtbase: apply latest KDE patches
-rw-r--r--community/qt5-qtbase/0001-fix-build-with-gcc11.patch113
-rw-r--r--community/qt5-qtbase/APKBUILD19
2 files changed, 11 insertions, 121 deletions
diff --git a/community/qt5-qtbase/0001-fix-build-with-gcc11.patch b/community/qt5-qtbase/0001-fix-build-with-gcc11.patch
deleted file mode 100644
index 547891df943..00000000000
--- a/community/qt5-qtbase/0001-fix-build-with-gcc11.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-From 8252ef5fc6d043004ddf7085e1c1fe1bf2ca39f7 Mon Sep 17 00:00:00 2001
-From: Thiago Macieira <thiago.macieira@intel.com>
-Date: Mon, 18 Jan 2021 07:40:54 -0800
-Subject: [PATCH 1/2] Fix build with GCC 11: include <limits>
-
-Fixes: QTBUG-90395
-Change-Id: Iecc74d2000eb40dfbe7bfffd165b5dd3708b7a40
-(cherry picked from commit 9c56d4da2ff631a8c1c30475bd792f6c86bda53c)
-Reviewed-by: Edward Welbourne <edward.welbourne@qt.io>
-(cherry picked from commit b2af6332ea37e45ab230a7a5d2d278f86d961b83)
----
- src/corelib/global/qendian.h | 6 ++++--
- src/corelib/global/qfloat16.h | 1 +
- 2 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/src/corelib/global/qendian.h b/src/corelib/global/qendian.h
-index 257efbbdbec..339f53abb60 100644
---- a/src/corelib/global/qendian.h
-+++ b/src/corelib/global/qendian.h
-@@ -1,7 +1,7 @@
- /****************************************************************************
- **
--** Copyright (C) 2016 The Qt Company Ltd.
--** Copyright (C) 2016 Intel Corporation.
-+** Copyright (C) 2021 The Qt Company Ltd.
-+** Copyright (C) 2021 Intel Corporation.
- ** Contact: https://www.qt.io/licensing/
- **
- ** This file is part of the QtCore module of the Qt Toolkit.
-@@ -44,6 +44,8 @@
- #include <QtCore/qfloat16.h>
- #include <QtCore/qglobal.h>
-
-+#include <limits>
-+
- // include stdlib.h and hope that it defines __GLIBC__ for glibc-based systems
- #include <stdlib.h>
- #include <string.h>
-diff --git a/src/corelib/global/qfloat16.h b/src/corelib/global/qfloat16.h
-index c7a9c87af32..5302be072ed 100644
---- a/src/corelib/global/qfloat16.h
-+++ b/src/corelib/global/qfloat16.h
-@@ -43,6 +43,7 @@
-
- #include <QtCore/qglobal.h>
- #include <QtCore/qmetatype.h>
-+#include <limits>
- #include <string.h>
-
- #if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__)
---
-GitLab
-
-
-From cb2da673f53815a5cfe15f50df49b98032429f9e Mon Sep 17 00:00:00 2001
-From: Ville Voutilainen <ville.voutilainen@qt.io>
-Date: Mon, 18 Jan 2021 09:58:17 +0200
-Subject: [PATCH 2/2] Build fixes for GCC 11
-
-Task-number: QTBUG-89977
-Change-Id: Ic1b7ddbffb8a0a00f8c621d09a868f1d94a52c21
-Reviewed-by: Lars Knoll <lars.knoll@qt.io>
-Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
-(cherry picked from commit 813a928c7c3cf98670b6043149880ed5c955efb9)
----
- src/corelib/text/qbytearraymatcher.h | 2 ++
- src/corelib/tools/qsharedpointer_impl.h | 3 ---
- src/plugins/platforms/xcb/qxcbwindow.cpp | 2 +-
- 3 files changed, 3 insertions(+), 4 deletions(-)
-
-diff --git a/src/corelib/text/qbytearraymatcher.h b/src/corelib/text/qbytearraymatcher.h
-index 0eedfc1d203..f5f9bef7b87 100644
---- a/src/corelib/text/qbytearraymatcher.h
-+++ b/src/corelib/text/qbytearraymatcher.h
-@@ -42,6 +42,8 @@
-
- #include <QtCore/qbytearray.h>
-
-+#include <limits>
-+
- QT_BEGIN_NAMESPACE
-
-
-diff --git a/src/corelib/tools/qsharedpointer_impl.h b/src/corelib/tools/qsharedpointer_impl.h
-index 790c187cb95..4aee98af537 100644
---- a/src/corelib/tools/qsharedpointer_impl.h
-+++ b/src/corelib/tools/qsharedpointer_impl.h
-@@ -155,9 +155,6 @@ namespace QtSharedPointer {
- #endif
- inline void checkQObjectShared(...) { }
- inline void setQObjectShared(...) { }
--
-- inline void operator delete(void *ptr) { ::operator delete(ptr); }
-- inline void operator delete(void *, void *) { }
- };
- // sizeof(ExternalRefCountData) = 12 (32-bit) / 16 (64-bit)
-
-diff --git a/src/plugins/platforms/xcb/qxcbwindow.cpp b/src/plugins/platforms/xcb/qxcbwindow.cpp
-index 9e7e1a55728..f0866a90ac2 100644
---- a/src/plugins/platforms/xcb/qxcbwindow.cpp
-+++ b/src/plugins/platforms/xcb/qxcbwindow.cpp
-@@ -698,7 +698,7 @@ void QXcbWindow::show()
- if (isTransient(window())) {
- const QWindow *tp = window()->transientParent();
- if (tp && tp->handle())
-- transientXcbParent = static_cast<const QXcbWindow *>(tp->handle())->winId();
-+ transientXcbParent = tp->handle()->winId();
- // Default to client leader if there is no transient parent, else modal dialogs can
- // be hidden by their parents.
- if (!transientXcbParent)
---
-GitLab
-
diff --git a/community/qt5-qtbase/APKBUILD b/community/qt5-qtbase/APKBUILD
index 6d934e1dc91..a257370d765 100644
--- a/community/qt5-qtbase/APKBUILD
+++ b/community/qt5-qtbase/APKBUILD
@@ -1,7 +1,8 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtbase
-pkgver=5.15.2
-pkgrel=3
+pkgver=5.15.3_git20210406
+pkgrel=0
+_commit="cb2da673f53815a5cfe15f50df49b98032429f9e"
pkgdesc="Qt5 - QtBase components"
url="https://qt.io/developers/"
arch="all"
@@ -59,16 +60,15 @@ makedepends="$depends_dev
"
subpackages="$pkgname-dev $pkgname-doc $_sub"
provides="qtbase"
-builddir="$srcdir/qtbase-everywhere-src-$pkgver"
+builddir="$srcdir/qtbase-$_commit"
case $pkgver in
*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
esac
-source="https://download.qt.io/$_rel/qt/${pkgver%.*}/$pkgver/submodules/qtbase-everywhere-src-$pkgver.tar.xz
+source="https://invent.kde.org/qt/qt/qtbase/-/archive/$_commit/qtbase-$_commit.tar.gz
qt-musl-iconv-no-bom.patch
- 0001-fix-build-with-gcc11.patch
"
_qt5_prefix=/usr/lib/qt5
@@ -90,6 +90,10 @@ prepare() {
-e "/^QMAKE_RPATH/s| -Wl,-rpath,||g" \
-e "/^QMAKE_LFLAGS\s/s|+=|+= $LDFLAGS|g" \
mkspecs/common/*.conf
+
+ # Make configure think we are running in a git directory
+ # This makes it symlink the include files to the right directory
+ mkdir .git
}
build() {
@@ -227,6 +231,5 @@ x11() {
return 0
}
-sha512sums="a549bfaf867d746ff744ab224eb65ac1bdcdac7e8457dfa379941b2b225a90442fcfc1e1175b9afb1f169468f8130b7ab917c67be67156520a4bfb5c92d304f9 qtbase-everywhere-src-5.15.2.tar.xz
-7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch
-f499ceba8af653412c2c68a18ce519299c22890329bf36d1f81c2e26d4c17cf9ae4aefa8bdf23c85b8d21c38d2c210fd57d1a34fe06f5776ad332f6831a50b83 0001-fix-build-with-gcc11.patch"
+sha512sums="f0a8c35a0bc21698ae1cd05ee729c4021cf0baddfd742a468105a0d61c19222714c552119e7a65443452d873e5b9e9b03799232ec63255f332696bde99435d1f qtbase-cb2da673f53815a5cfe15f50df49b98032429f9e.tar.gz
+7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch"