aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Benden <joe@benden.us>2019-07-17 23:19:47 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-07-21 01:08:36 -0300
commitb7800e184a122f9eafa41fd0298fa144894edd7a (patch)
tree3d6c2a9665180776deb8661ed08e460d468e105f
parent4488eb52f455d98a9c1cc0252a497237b48e651c (diff)
testing/stgit: new aport
http://www.procode.org/stgit/ Manage a stack of patches using GIT as a backend Signed-off-by: Joseph Benden <joe@benden.us>
-rw-r--r--testing/stgit/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/stgit/APKBUILD b/testing/stgit/APKBUILD
new file mode 100644
index 00000000000..a9755c7301f
--- /dev/null
+++ b/testing/stgit/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Joseph Benden <joe@benden.us>
+# Maintainer: Joseph Benden <joe@benden.us>
+
+pkgname=stgit
+pkgver=0.19
+pkgrel=0
+pkgdesc="Manage a stack of patches using GIT as a backend"
+arch="noarch"
+url="http://www.procode.org/stgit/"
+license="GPL-2.0-or-later"
+options="!check" # unit-tests fail due to iconv usage
+depends="git python3"
+makedepends="asciidoc xmlto perl"
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/ctmarinas/stgit/archive/v${pkgver}.tar.gz"
+
+prepare() {
+ default_prepare
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${pkgver}\"" > stgit/builtin_version.py
+}
+
+check() {
+ make \
+ PYTHON=python3 \
+ prefix=/usr \
+ mandir=/usr/share/man/ \
+ test
+}
+
+build() {
+ make \
+ PYTHON=python3 \
+ prefix=/usr \
+ mandir=/usr/share/man/ \
+ all doc
+}
+
+package() {
+ make \
+ DESTDIR="$pkgdir" \
+ PYTHON=python3 \
+ prefix=/usr \
+ mandir=/usr/share/man/ \
+ install install-doc
+}
+
+sha512sums="6b4f184b91614961d759e8abd505856d74354e7d269d013a448e6795ecb35054277c319ee97f1df9bee3ed4861b70090133ed4f156c96908c2182ed4652304ba stgit-0.19.tar.gz"