aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-03 00:45:36 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 19:50:03 +0000
commitba65df0be4bfebe7ead7289946e5a64876383677 (patch)
tree1b3bab9e856f8112e6f2cd19fad3a3570711c57b
parentd7dcd2ec89c28d70de9a96041b162a1e2832ae27 (diff)
testing/py2-linecache2: modernize and fix build
- lighten dependency load - Add missing dependencies - Work around pbr git problems - Explain why check is disabled
-rw-r--r--testing/py2-linecache2/APKBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/testing/py2-linecache2/APKBUILD b/testing/py2-linecache2/APKBUILD
index 87df903b261..08d52367271 100644
--- a/testing/py2-linecache2/APKBUILD
+++ b/testing/py2-linecache2/APKBUILD
@@ -3,30 +3,23 @@
pkgname=py2-linecache2
_pkgname=${pkgname#py2-*}
pkgver=1.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Backport of the Python3 stdlib linecache module"
url="https://github.com/testing-cabal/linecache2"
arch="noarch"
-license="PSF"
+license="Python-2.0"
depends="python2"
-makedepends="python2-dev py-setuptools"
-options="!check" # temp disable until py2-unittest2 is in repos
-#checkdepends="py2-fixtures py2-unittest2 py2-traceback2 py2-six py2-pbr py2-testtools py2-extras"
+makedepends="py-setuptools py-pbr git"
+options="!check" # Causes cyclic dependency loop between it py2-traceback2 and py2-unittest2
source="$pkgname-$pkgver.tar.gz::https://github.com/testing-cabal/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
+ git init # Work around pbr
python2 setup.py build
}
-check() {
- cd "$builddir"
- python2 -m unittest2 discover
-}
-
package() {
- cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir"
}