aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Marz <main@lmarz.org>2022-09-25 11:38:56 +0200
committeralice <alice@ayaya.dev>2022-09-25 10:01:50 +0000
commitbbaa7e90b27a0b0576dff6acc353685ea24567ab (patch)
tree4a40255365c61a1a8cf4526278ea88e5d45f4da4
parentf726aa90ceb5038b5ec312f685c29e0be1bb8e9e (diff)
community/blender: upgrade to 3.3.0
-rw-r--r--community/blender/0001-musl-fixes.patch27
-rw-r--r--community/blender/0002-fix-linking-issue.patch8
-rw-r--r--community/blender/0003-increase-thread-stack-size-for-musl.patch4
-rw-r--r--community/blender/APKBUILD12
4 files changed, 16 insertions, 35 deletions
diff --git a/community/blender/0001-musl-fixes.patch b/community/blender/0001-musl-fixes.patch
index 6256340c754..c7ca53c8bb1 100644
--- a/community/blender/0001-musl-fixes.patch
+++ b/community/blender/0001-musl-fixes.patch
@@ -1,4 +1,4 @@
-From e51acbbc4317b60064014b12d00fc17b91243765 Mon Sep 17 00:00:00 2001
+From 8db82091f3e7631e95032bd6f446522e756eee63 Mon Sep 17 00:00:00 2001
From: Leon Marz <lmarz@cs.uni-frankfurt.de>
Date: Wed, 25 Nov 2020 10:10:41 +0100
Subject: [PATCH 1/3] musl fixes
@@ -7,11 +7,10 @@ Original patch by Nathanael Copa
---
extern/glog/src/config_linux.h | 1 -
intern/guardedalloc/intern/mallocn_intern.h | 2 +-
- intern/libc_compat/libc_compat.c | 2 --
source/blender/blenlib/intern/system.c | 4 +++-
source/blender/gpu/GPU_vertex_buffer.h | 1 -
source/creator/creator_signals.c | 2 +-
- 6 files changed, 5 insertions(+), 7 deletions(-)
+ 5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/extern/glog/src/config_linux.h b/extern/glog/src/config_linux.h
index b3a3325..946095a 100644
@@ -38,24 +37,6 @@ index f8b16ff..0bf7719 100644
defined(__GLIBC__)
# include <malloc.h>
# define HAVE_MALLOC_STATS
-diff --git a/intern/libc_compat/libc_compat.c b/intern/libc_compat/libc_compat.c
-index 85a6b43..28499a4 100644
---- a/intern/libc_compat/libc_compat.c
-+++ b/intern/libc_compat/libc_compat.c
-@@ -13,7 +13,6 @@
- # include <features.h>
- # include <math.h>
-
--# if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 31)
-
- double __exp_finite(double x);
- double __exp2_finite(double x);
-@@ -112,5 +111,4 @@ float __powf_finite(float x, float y)
- return powf(x, y);
- }
-
--# endif /* __GLIBC_PREREQ */
- #endif /* __linux__ */
diff --git a/source/blender/blenlib/intern/system.c b/source/blender/blenlib/intern/system.c
index 35e26e0..9a172dd 100644
--- a/source/blender/blenlib/intern/system.c
@@ -80,7 +61,7 @@ index 35e26e0..9a172dd 100644
# define SIZE 100
void *buffer[SIZE];
diff --git a/source/blender/gpu/GPU_vertex_buffer.h b/source/blender/gpu/GPU_vertex_buffer.h
-index fe6ed7e..05cd7e0 100644
+index 722ef87..04611d5 100644
--- a/source/blender/gpu/GPU_vertex_buffer.h
+++ b/source/blender/gpu/GPU_vertex_buffer.h
@@ -133,7 +133,6 @@ GPU_INLINE void *GPU_vertbuf_raw_step(GPUVertBufRaw *a)
@@ -105,5 +86,5 @@ index 76423d7..af20437 100644
# endif /* defined(__linux__) && defined(__GNUC__) */
# if defined(OSX_SSE_FPE)
--
-2.36.1
+2.37.3
diff --git a/community/blender/0002-fix-linking-issue.patch b/community/blender/0002-fix-linking-issue.patch
index b0a89a1f284..bb0533a36ce 100644
--- a/community/blender/0002-fix-linking-issue.patch
+++ b/community/blender/0002-fix-linking-issue.patch
@@ -1,4 +1,4 @@
-From 0c54af73d5cf71675ebd9776a892e1c47617e3ac Mon Sep 17 00:00:00 2001
+From f2550e3e7b1fb2e31a4db6eb8419779e5cbb81e3 Mon Sep 17 00:00:00 2001
From: Leon Marz <lmarz@cs.uni-frankfurt.de>
Date: Tue, 1 Sep 2020 09:11:18 +0200
Subject: [PATCH 2/3] fix linking issue
@@ -8,10 +8,10 @@ Subject: [PATCH 2/3] fix linking issue
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/intern/ghost/CMakeLists.txt b/intern/ghost/CMakeLists.txt
-index 9421ede..bcc5017 100644
+index c681dc3..b746060 100644
--- a/intern/ghost/CMakeLists.txt
+++ b/intern/ghost/CMakeLists.txt
-@@ -519,5 +519,5 @@ if(WITH_XR_OPENXR)
+@@ -562,5 +562,5 @@ if(WITH_XR_OPENXR)
endif()
add_definitions(${GL_DEFINITIONS})
@@ -19,5 +19,5 @@ index 9421ede..bcc5017 100644
+list(APPEND LIB "-lX11" "-lXi" "-lXxf86vm" "-lXfixes" "-lXrender")
blender_add_lib(bf_intern_ghost "${SRC}" "${INC}" "${INC_SYS}" "${LIB}")
--
-2.36.1
+2.37.3
diff --git a/community/blender/0003-increase-thread-stack-size-for-musl.patch b/community/blender/0003-increase-thread-stack-size-for-musl.patch
index 65c33346fc3..17036e2b09d 100644
--- a/community/blender/0003-increase-thread-stack-size-for-musl.patch
+++ b/community/blender/0003-increase-thread-stack-size-for-musl.patch
@@ -1,4 +1,4 @@
-From bf4baebff258795918bcb3ad95f74eb187018554 Mon Sep 17 00:00:00 2001
+From 55fe34471a3ed0e88756690c68028f1ad20e472b Mon Sep 17 00:00:00 2001
From: Damian Kurek <starfire24680@gmail.com>
Date: Fri, 3 Dec 2021 17:55:35 +0000
Subject: [PATCH 3/3] increase thread stack size for musl
@@ -44,5 +44,5 @@ index 8d7dc45..f3040cf 100644
#else
std::thread std_thread;
--
-2.36.1
+2.37.3
diff --git a/community/blender/APKBUILD b/community/blender/APKBUILD
index 7bfa3bc72b5..9d4ee0dce75 100644
--- a/community/blender/APKBUILD
+++ b/community/blender/APKBUILD
@@ -2,9 +2,9 @@
# Contributor: Leon Marz <main@lmarz.org>
# Maintainer: Leon Marz <main@lmarz.org>
pkgname=blender
-pkgver=3.2.2
+pkgver=3.3.0
_pkgver=${pkgver%.[0-9]}
-pkgrel=2
+pkgrel=0
pkgdesc="3D Creation/Animation/Publishing System"
url="https://www.blender.org/"
arch="x86_64 aarch64" # limited by openvdb
@@ -147,8 +147,8 @@ python() {
}
sha512sums="
-963c8f6510503f861c55d900480c5e4cd643974fc88439a62c672c96e049ff222422ddb20d8e82932fd829c078aafd9ea6a7fcc16434d115f49f61b4943c0c04 blender-3.2.2.tar.xz
-05074e900e70a5acc1fb6ef85afcdda6cb1e2546544fd78c09502d5b75e4e52a083cdaf4d71887c6f1fceaba1603dd138f1fa8e4d5a2fb826b955f6d27b0a81f 0001-musl-fixes.patch
-0a9fd519c8bbcfca121f158e0d78224b55412cb704ca586564d77409582336c1ed2681ff0b8e8b103d6fbe8fd6a0cc9697447ffaefb90c90ee458273fbdd7fd5 0002-fix-linking-issue.patch
-27704667a06577847432df3c55de07a7d07d34f076b24db243c11c21d9d6a485367b0f074ab652bc9a85ccefcb0e6a134a09a896f980a9652ee06fc1df30ea97 0003-increase-thread-stack-size-for-musl.patch
+5257cbb410a26652077c4ccbfbe949ca9daf7d5f8cde5d518ac175dda6b103c56de08e1643fea1988296e04fa3232f21a9eec566c3eef5436960cdc88de19243 blender-3.3.0.tar.xz
+8f1beef2b85d6364c78476407bb9a0441b69f34f8803785e8c982039bd139a90bf2952d6c40985526e2ff00ba175138a173b3eb74752733425d096930db3ee92 0001-musl-fixes.patch
+92abea860f724dc37db4021efde485adb90389f233a78aa4217b07d6f8cacd47f78844b462ddfdfa1948ae06934cc49ebf38b5d20f9fb1f63153c657e11a62c0 0002-fix-linking-issue.patch
+f9846fcd741280eff4fad5bf5a5cfbc5fd10ab5f69a2a755425cbe2fa5386615b102181769e3e0367c04bdd8a2600d3e490d3f8d9e511fb1bbb8de48c3e043ad 0003-increase-thread-stack-size-for-musl.patch
"