aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 03:35:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 07:58:06 -0300
commitbd22c50afe3eb3986224edbda4ba5562625322a9 (patch)
treedc6a60fd0fca30e3b427922ad7393f4321ef3233
parentc8f2b570d0cfe708e200e498145c1b53812fa23b (diff)
community/lua-binaryheap: enable luajit on s390x
-rw-r--r--community/lua-binaryheap/APKBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/community/lua-binaryheap/APKBUILD b/community/lua-binaryheap/APKBUILD
index a6873d7fc20..17574c6f70f 100644
--- a/community/lua-binaryheap/APKBUILD
+++ b/community/lua-binaryheap/APKBUILD
@@ -10,17 +10,10 @@ url="https://tieske.github.io/binaryheap.lua/"
arch="noarch"
license="MIT"
depends="lua"
-checkdepends="lua-busted"
-provides=""
+checkdepends="lua-busted luajit"
source="https://github.com/Tieske/binaryheap.lua/archive/version_$_pkgver/binaryheap.lua-$pkgver.tar.gz"
builddir="$srcdir/binaryheap.lua-version_$_pkgver"
-case "$CARCH" in
- # luajit is not available for s390x
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
checkdepends="$checkdepends lua$_v lua$_v-busted"
@@ -33,12 +26,12 @@ prepare() {
}
check() {
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions jit; do
msg "Testing on lua$lver"
lua$lver /usr/bin/busted || {
# FIXME: Allow failure on Lua 5.3.
# https://github.com/Tieske/binaryheap.lua/issues/17
- [ $lver = 5.3 ] || return 1
+ [ $lver = 5.3 ]
}
done
}