aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-03 03:04:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-12 17:17:19 -0300
commitbdcff9d4e80ef8dc5a9d920397f74dd1352424fe (patch)
tree45ab66cf7f99801d1a70c864928219c0c204d9cc
parent7d88323e8b1e221289e3bf376d827562705d4736 (diff)
downloadaports-bdcff9d4e80ef8dc5a9d920397f74dd1352424fe.tar.gz
aports-bdcff9d4e80ef8dc5a9d920397f74dd1352424fe.tar.bz2
aports-bdcff9d4e80ef8dc5a9d920397f74dd1352424fe.tar.xz
community/ruby-ffi: enable tests, fix license
-rw-r--r--community/ruby-ffi/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/community/ruby-ffi/APKBUILD b/community/ruby-ffi/APKBUILD
index 87ba78a615..2c74826f22 100644
--- a/community/ruby-ffi/APKBUILD
+++ b/community/ruby-ffi/APKBUILD
@@ -3,21 +3,18 @@
pkgname=ruby-ffi
_gemname=ffi
pkgver=1.10.0
-pkgrel=0
+pkgrel=1
pkgdesc="Ruby FFI library"
url="https://github.com/ffi/ffi"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
makedepends="libffi-dev ruby ruby-dev"
install="$pkgname.post-install"
source="$pkgname-$pkgver.tar.gz::https://github.com/ffi/$_gemname/archive/$pkgver.tar.gz
gemspec.patch"
builddir="$srcdir/$_gemname-$pkgver"
-options="!check" # does not work with PaX (it'd need paxmark -m /usr/bin/ruby)
build() {
- cd "$builddir"
-
gem build $_gemname.gemspec
gem install --local \
--install-dir dist \
@@ -28,8 +25,6 @@ build() {
}
check() {
- cd "$builddir"
-
# Install missing development dependencies needed and used only for running
# tests. We can't install them easily with bundler, because there's
# no way how to force it to NOT update already satisifed dependencies.