aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-08-18 04:32:49 +0200
committerptrcnull <git@ptrcnull.me>2022-08-18 04:33:12 +0200
commitbf1a17768076418a4d28e1150c192fa63746fb7e (patch)
tree79ee9474aecd549c74ac831340f1bf74abc6eb27
parent4223fd4ac30704cc309b03046824e48e9dcd9025 (diff)
testing/*: deduplicate dependencies
-rw-r--r--testing/hime/APKBUILD2
-rw-r--r--testing/kimchi/APKBUILD1
-rw-r--r--testing/kodi-game-libretro-atari800/APKBUILD2
-rw-r--r--testing/kodi-game-libretro-beetle-psx/APKBUILD2
-rw-r--r--testing/kodi-game-libretro-desmume/APKBUILD2
-rw-r--r--testing/kodi-game-libretro-fbneo/APKBUILD2
-rw-r--r--testing/kopano-core/APKBUILD1
-rw-r--r--testing/kopano-webapp/APKBUILD2
-rw-r--r--testing/lxd-feature/APKBUILD1
-rw-r--r--testing/m2r2/APKBUILD1
-rw-r--r--testing/ocaml-zarith/APKBUILD2
-rw-r--r--testing/paperde/APKBUILD2
-rw-r--r--testing/perl-cairo-gobject/APKBUILD3
-rw-r--r--testing/perl-future-asyncawait/APKBUILD2
-rw-r--r--testing/perl-glib-object-introspection/APKBUILD2
-rw-r--r--testing/perl-gtk3/APKBUILD2
-rw-r--r--testing/perl-object-pad/APKBUILD2
-rw-r--r--testing/perl-syntax-keyword-defer/APKBUILD2
-rw-r--r--testing/perl-syntax-keyword-try/APKBUILD2
-rw-r--r--testing/py3-libmdbx/APKBUILD4
-rw-r--r--testing/refind/APKBUILD2
-rw-r--r--testing/sems/APKBUILD2
-rw-r--r--testing/straw-viewer/APKBUILD3
-rw-r--r--testing/thumbdrives/APKBUILD2
-rw-r--r--testing/tic-80/APKBUILD3
25 files changed, 20 insertions, 31 deletions
diff --git a/testing/hime/APKBUILD b/testing/hime/APKBUILD
index ac64a7dc5f6..6d6898b5788 100644
--- a/testing/hime/APKBUILD
+++ b/testing/hime/APKBUILD
@@ -10,9 +10,7 @@ arch="all"
license="LGPL-2.1-or-later AND GPL-2.0-or-later"
depends="bash cmd:whereis"
makedepends="
- bash
libxtst-dev
- cmd:whereis
cmd:iconv
anthy-dev
libchewing-dev
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index 991300aceed..5c59e2e54e6 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -51,7 +51,6 @@ makedepends="
py3-pytest
py3-setuptools
python3-dev
- spice-html5
"
checkdepends="py3-requests"
options="!check" # depends on jaraco
diff --git a/testing/kodi-game-libretro-atari800/APKBUILD b/testing/kodi-game-libretro-atari800/APKBUILD
index cb4ff8f214f..25de7d371b7 100644
--- a/testing/kodi-game-libretro-atari800/APKBUILD
+++ b/testing/kodi-game-libretro-atari800/APKBUILD
@@ -9,8 +9,8 @@ options="!check" # no test suite
url="https://github.com/kodi-game/game.libretro.atari800"
arch="x86 x86_64 aarch64 armv7" # kodi
license="GPL-2.0-only"
-makedepends="cmake libretro-atari800 kodi-dev"
depends="kodi-game-libretro libretro-atari800"
+makedepends="cmake kodi-dev"
source="$pkgname-$pkgver-$_realname.tar.gz::https://github.com/kodi-game/game.libretro.atari800/archive/$pkgver-$_realname.tar.gz"
builddir="$srcdir/game.libretro.atari800-$pkgver-$_realname"
diff --git a/testing/kodi-game-libretro-beetle-psx/APKBUILD b/testing/kodi-game-libretro-beetle-psx/APKBUILD
index 182e0bde31c..6cb98c4c259 100644
--- a/testing/kodi-game-libretro-beetle-psx/APKBUILD
+++ b/testing/kodi-game-libretro-beetle-psx/APKBUILD
@@ -9,8 +9,8 @@ options="!check" # no test suite
url="https://github.com/kodi-game/game.libretro.beetle-psx"
arch="x86 x86_64 aarch64 armv7" # kodi
license="GPL-2.0-or-later"
-makedepends="cmake libretro-beetle-psx kodi-dev"
depends="kodi-game-libretro libretro-beetle-psx"
+makedepends="cmake kodi-dev"
source="$pkgname-$pkgver-$_realname.tar.gz::https://github.com/kodi-game/game.libretro.beetle-psx/archive/$pkgver-$_realname.tar.gz"
builddir="$srcdir/game.libretro.beetle-psx-$pkgver-$_realname"
diff --git a/testing/kodi-game-libretro-desmume/APKBUILD b/testing/kodi-game-libretro-desmume/APKBUILD
index 4ba9f510e27..bce84e02a1c 100644
--- a/testing/kodi-game-libretro-desmume/APKBUILD
+++ b/testing/kodi-game-libretro-desmume/APKBUILD
@@ -9,8 +9,8 @@ options="!check" # no test suite
url="https://github.com/kodi-game/game.libretro.desmume"
arch="x86 x86_64 aarch64 armv7" # kodi
license="GPL-2.0-or-later"
-makedepends="cmake libretro-desmume kodi-dev"
depends="kodi-game-libretro libretro-desmume"
+makedepends="cmake kodi-dev"
source="$pkgname-$pkgver-$_realname.tar.gz::https://github.com/kodi-game/game.libretro.desmume/archive/$pkgver-$_realname.tar.gz"
builddir="$srcdir/game.libretro.desmume-$pkgver-$_realname"
diff --git a/testing/kodi-game-libretro-fbneo/APKBUILD b/testing/kodi-game-libretro-fbneo/APKBUILD
index c6b327e7597..8fc0820ac5f 100644
--- a/testing/kodi-game-libretro-fbneo/APKBUILD
+++ b/testing/kodi-game-libretro-fbneo/APKBUILD
@@ -9,8 +9,8 @@ options="!check" # no test suite
url="https://github.com/kodi-game/game.libretro.fbneo"
arch="x86 x86_64 aarch64 armv7" # kodi is available only on those architectures
license="GPL-2.0-or-later"
-makedepends="cmake libretro-fbneo kodi-dev"
depends="kodi-game-libretro libretro-fbneo"
+makedepends="cmake kodi-dev"
source="$pkgname-$pkgver-$_realname.tar.gz::https://github.com/kodi-game/game.libretro.fbneo/archive/$pkgver-$_realname.tar.gz"
builddir="$srcdir/game.libretro.fbneo-$pkgver-$_realname"
diff --git a/testing/kopano-core/APKBUILD b/testing/kopano-core/APKBUILD
index 09112a64d5d..5211327c45a 100644
--- a/testing/kopano-core/APKBUILD
+++ b/testing/kopano-core/APKBUILD
@@ -38,7 +38,6 @@ makedepends="
swig3
xapian-core-dev
xmlto
- xorgproto
"
pkgusers="kopano-core kopano-gateway kopano-ical postfix"
pkggroups="kopano http kopano-diraccess"
diff --git a/testing/kopano-webapp/APKBUILD b/testing/kopano-webapp/APKBUILD
index f53038460dc..4011130b851 100644
--- a/testing/kopano-webapp/APKBUILD
+++ b/testing/kopano-webapp/APKBUILD
@@ -10,7 +10,7 @@ license="AGPL-3.0-only"
options="!check" # No test suite
depends="php7 php7-fpm php7-json php7-gettext php7-iconv php7-session php7-openssl php7-simplexml php7-soap"
# kopano-core necessary for mapi php module
-makedepends="apache-ant openjdk8 kopano-core bash gettext-dev libxml2-utils php7-soap"
+makedepends="apache-ant openjdk8 kopano-core bash gettext-dev libxml2-utils"
replaces="zarafa-webapp"
subpackages="
kopano-webapp-contactfax:simple_plugin_splitfunc:noarch
diff --git a/testing/lxd-feature/APKBUILD b/testing/lxd-feature/APKBUILD
index 9c604170fbe..333f0008cb9 100644
--- a/testing/lxd-feature/APKBUILD
+++ b/testing/lxd-feature/APKBUILD
@@ -36,7 +36,6 @@ makedepends="
libcap-dev
linux-headers
- rsync
go
intltool
diff --git a/testing/m2r2/APKBUILD b/testing/m2r2/APKBUILD
index e44364b3dc2..dd2a91bd173 100644
--- a/testing/m2r2/APKBUILD
+++ b/testing/m2r2/APKBUILD
@@ -9,7 +9,6 @@ url="https://crossnox.github.io/m2r2"
arch="all"
license="MIT"
depends="python3 py3-docutils py3-mistune1 py3-setuptools py3-setuptools_scm"
-makedepends="py3-setuptools"
checkdepends="py3-pytest"
source="$pkgname-$pkgver.zip::https://github.com/CrossNox/m2r2/archive/$_githash.zip
no-circular-import.patch
diff --git a/testing/ocaml-zarith/APKBUILD b/testing/ocaml-zarith/APKBUILD
index efa04978554..81e63f92822 100644
--- a/testing/ocaml-zarith/APKBUILD
+++ b/testing/ocaml-zarith/APKBUILD
@@ -8,7 +8,7 @@ url="https://github.com/ocaml/Zarith"
arch="all !riscv64" # limited by ocaml aport
license="custom"
depends="gmp-dev"
-makedepends="ocaml ocaml-findlib ocaml-compiler-libs ocaml-ocamldoc gmp-dev"
+makedepends="ocaml ocaml-findlib ocaml-compiler-libs ocaml-ocamldoc"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/Zarith/archive/refs/tags/release-$pkgver.tar.gz"
builddir="$srcdir/Zarith-release-$pkgver"
diff --git a/testing/paperde/APKBUILD b/testing/paperde/APKBUILD
index 813a1534b87..7f2c2a911bc 100644
--- a/testing/paperde/APKBUILD
+++ b/testing/paperde/APKBUILD
@@ -10,7 +10,7 @@ arch="all !armhf !s390x !riscv64"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtbase-dev libcprime-dev libcsys-dev wayfire wayland-protocols libdbusmenu-qt-dev qt5-qttools-dev qt5-qtsvg-dev qt5-qtwayland-dev upower-dev xdg-desktop-portal cmake ninja"
-makedepends="qt5-qtbase-dev extra-cmake-modules"
+makedepends="extra-cmake-modules"
source="https://gitlab.com/cubocore/paper/paperde/-/archive/v$pkgver/paperde-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
options="!check" # No test suite
diff --git a/testing/perl-cairo-gobject/APKBUILD b/testing/perl-cairo-gobject/APKBUILD
index d8bfd630ddc..6c9c71f435a 100644
--- a/testing/perl-cairo-gobject/APKBUILD
+++ b/testing/perl-cairo-gobject/APKBUILD
@@ -11,8 +11,7 @@ url="https://metacpan.org/release/Cairo-GObject/"
arch="all"
license="GPL-2.0-or-later"
depends="perl perl-cairo perl-extutils-depends perl-extutils-pkgconfig perl-glib"
-makedepends="perl-dev perl-cairo perl-extutils-pkgconfig perl-glib perl-extutils-depends
- cairo-dev"
+makedepends="perl-dev cairo-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/X/XA/XAOC/Cairo-GObject-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
diff --git a/testing/perl-future-asyncawait/APKBUILD b/testing/perl-future-asyncawait/APKBUILD
index 294658e7ffe..55a4180af0b 100644
--- a/testing/perl-future-asyncawait/APKBUILD
+++ b/testing/perl-future-asyncawait/APKBUILD
@@ -11,7 +11,7 @@ url="https://metacpan.org/release/Future-AsyncAwait/"
arch="all"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-future perl-xs-parse-sublike perl-xs-parse-keyword"
-makedepends="perl-dev perl-xs-parse-keyword perl-module-build perl-xs-parse-sublike perl-module-build"
+makedepends="perl-dev perl-module-build"
checkdepends="perl-test-refcount perl-future perl-test-fatal"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Future-AsyncAwait-$pkgver.tar.gz"
diff --git a/testing/perl-glib-object-introspection/APKBUILD b/testing/perl-glib-object-introspection/APKBUILD
index 3deb8c8ef9b..30cf0f0afd9 100644
--- a/testing/perl-glib-object-introspection/APKBUILD
+++ b/testing/perl-glib-object-introspection/APKBUILD
@@ -11,7 +11,7 @@ url="https://metacpan.org/release/Glib-Object-Introspection/"
arch="all"
license="GPL-2.0-or-later"
depends="perl perl-glib perl-extutils-pkgconfig perl-extutils-depends"
-makedepends="perl-dev perl-extutils-depends perl-extutils-pkgconfig perl-glib gobject-introspection-dev"
+makedepends="perl-dev gobject-introspection-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/X/XA/XAOC/Glib-Object-Introspection-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
diff --git a/testing/perl-gtk3/APKBUILD b/testing/perl-gtk3/APKBUILD
index 1defa9a4643..c6ad163153b 100644
--- a/testing/perl-gtk3/APKBUILD
+++ b/testing/perl-gtk3/APKBUILD
@@ -11,7 +11,7 @@ url="https://metacpan.org/release/Gtk3/"
arch="noarch"
license="GPL-2.0-or-later"
depends="perl perl-glib-object-introspection perl-cairo-gobject"
-makedepends="perl-cairo perl-glib-object-introspection perl-cairo-gobject gtk+3.0-dev"
+makedepends="perl-cairo gtk+3.0-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/X/XA/XAOC/Gtk3-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
diff --git a/testing/perl-object-pad/APKBUILD b/testing/perl-object-pad/APKBUILD
index 380f36a60bb..f5b9fd829f0 100644
--- a/testing/perl-object-pad/APKBUILD
+++ b/testing/perl-object-pad/APKBUILD
@@ -11,7 +11,7 @@ url="https://metacpan.org/release/Object-Pad/"
arch="all"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-xs-parse-sublike perl-xs-parse-keyword"
-makedepends="perl-dev perl-module-build perl-xs-parse-sublike perl-xs-parse-keyword perl-module-build"
+makedepends="perl-dev perl-module-build"
checkdepends="perl-test-refcount perl-data-dump perl-test-fatal"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Object-Pad-$pkgver.tar.gz"
diff --git a/testing/perl-syntax-keyword-defer/APKBUILD b/testing/perl-syntax-keyword-defer/APKBUILD
index cf26daa3f04..cb1d2e63b47 100644
--- a/testing/perl-syntax-keyword-defer/APKBUILD
+++ b/testing/perl-syntax-keyword-defer/APKBUILD
@@ -11,7 +11,7 @@ url="https://metacpan.org/release/Syntax-Keyword-Defer/"
arch="all"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-xs-parse-keyword"
-makedepends="perl-dev perl-xs-parse-keyword perl-module-build perl-module-build"
+makedepends="perl-dev perl-module-build"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Syntax-Keyword-Defer-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
diff --git a/testing/perl-syntax-keyword-try/APKBUILD b/testing/perl-syntax-keyword-try/APKBUILD
index 8c9e3bb34a7..f9f5296f576 100644
--- a/testing/perl-syntax-keyword-try/APKBUILD
+++ b/testing/perl-syntax-keyword-try/APKBUILD
@@ -11,7 +11,7 @@ url="https://metacpan.org/release/Syntax-Keyword-Try/"
arch="all"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-xs-parse-keyword"
-makedepends="perl-dev perl-xs-parse-keyword perl-module-build perl-module-build"
+makedepends="perl-dev perl-module-build"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Syntax-Keyword-Try-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
diff --git a/testing/py3-libmdbx/APKBUILD b/testing/py3-libmdbx/APKBUILD
index a0b0a1595b4..fbe2d9ab76a 100644
--- a/testing/py3-libmdbx/APKBUILD
+++ b/testing/py3-libmdbx/APKBUILD
@@ -7,8 +7,8 @@ url="https://gitlab.com/thermi/py3-libmdbx/"
arch="noarch !ppc64le" # test case segfaults in ppc64le
license="OLDAP-2.8"
depends="libmdbx"
-makedepends="py3-setuptools libmdbx"
-checkdepends="py3-pytest libmdbx"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="py3-libmdbx-$pkgver.tar.gz::https://gitlab.com/Thermi/py3-libmdbx/-/archive/v$pkgver/py3-libmdbx-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
diff --git a/testing/refind/APKBUILD b/testing/refind/APKBUILD
index 1d0d8d156d3..a3fe71fcff2 100644
--- a/testing/refind/APKBUILD
+++ b/testing/refind/APKBUILD
@@ -9,7 +9,7 @@ arch="x86_64"
options="!check" # No test suite.
license="GPL-3.0-only"
depends="bash efibootmgr lsblk"
-makedepends="gnu-efi-dev bash linux-headers"
+makedepends="gnu-efi-dev linux-headers"
subpackages="$pkgname-doc"
source="https://sourceforge.net/projects/refind/files/$pkgver/refind-src-$pkgver.tar.gz
01-missing-always-inline.patch
diff --git a/testing/sems/APKBUILD b/testing/sems/APKBUILD
index a76481a9e25..437049b2b19 100644
--- a/testing/sems/APKBUILD
+++ b/testing/sems/APKBUILD
@@ -13,7 +13,7 @@ pkgusers="sems"
pkggroups="sems"
install="$pkgname.pre-install"
depends="python3 bash"
-makedepends="cmake bash openssl-dev>3 linux-headers
+makedepends="cmake openssl-dev>3 linux-headers
libsamplerate-dev spandsp-dev flite-dev gsm-dev speex-dev
libevent-dev libev-dev lame-dev opus-dev tiff-dev"
subpackages="$pkgname-doc $pkgname-conference
diff --git a/testing/straw-viewer/APKBUILD b/testing/straw-viewer/APKBUILD
index 934d3e582c9..a407ce72b77 100644
--- a/testing/straw-viewer/APKBUILD
+++ b/testing/straw-viewer/APKBUILD
@@ -10,8 +10,7 @@ license="Artistic-2.0 License"
depends="perl perl-gtk3 perl-file-sharedir perl-data-dump perl-json-xs
perl-lwp-protocol-https perl-term-readline-gnu"
subpackages="$pkgname-doc"
-makedepends="perl-dev perl-libwww perl-json perl-json-xs perl-lwp-protocol-https
- perl-data-dump perl-gtk3 perl-file-sharedir perl-term-readline-gnu
+makedepends="perl-dev perl-libwww perl-json
perl-unicode-linebreak perl-module-build
"
source="straw-viewer-$pkgver.tar.gz::https://github.com/trizen/straw-viewer/archive/$pkgver.tar.gz"
diff --git a/testing/thumbdrives/APKBUILD b/testing/thumbdrives/APKBUILD
index 81035630e79..6ec7059ff1d 100644
--- a/testing/thumbdrives/APKBUILD
+++ b/testing/thumbdrives/APKBUILD
@@ -7,7 +7,7 @@ url="https://git.sr.ht/~martijnbraam/thumbdrives"
arch="noarch"
license="MIT"
depends="python3 py3-gobject3 py3-xdg py3-setuptools gtk+3.0 libhandy"
-makedepends="py3-setuptools glib-dev libhandy-dev meson ninja"
+makedepends="glib-dev libhandy-dev meson ninja"
source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~martijnbraam/thumbdrives/archive/$pkgver.tar.gz"
options="!check" # There's no testsuite
diff --git a/testing/tic-80/APKBUILD b/testing/tic-80/APKBUILD
index d7c66107f3f..f3350131c40 100644
--- a/testing/tic-80/APKBUILD
+++ b/testing/tic-80/APKBUILD
@@ -17,7 +17,6 @@ depends="
"
makedepends="
cmake
- fennel5.3
freeglut-dev
giflib-dev
glu-dev
@@ -26,10 +25,8 @@ makedepends="
libpng-dev
libuv-dev
lua5.3-dev
- lua5.3-moonscript
pulseaudio-dev
ruby-dev
- ruby-rake
samurai
sdl2-dev
zlib-dev