aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2022-05-02 04:46:39 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2022-05-02 04:46:39 +0000
commitbf78e57395d392ca297ec9c590223f2af074d732 (patch)
tree0ded6f6e7e83e0133a3deeedefbd51f93ca72174
parentcddd6b56dc91ebe2eeef10a802ea6ca75d36fe92 (diff)
Revert "main/nginx: prevent forking in the global scope"
Accidentally pushed before accepted. This reverts commit cddd6b56dc91ebe2eeef10a802ea6ca75d36fe92.
-rw-r--r--main/nginx/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 93f3f43fc74..dfa400008da 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -131,12 +131,7 @@ _add_module() {
# Don't add new flag and source if it's already there, i.e. two or more
# modules share the same source (e.g. geoip2 that provides http-geoip2
# and stream-geoip2).
- local present=false
- case "$_extra_flags" in
- *="$srcdir/$dirname"*) present=true;;
- esac
-
- if ! $present; then
+ if ! printf '%s\n' $_extra_flags | grep -qFw "$srcdir/$dirname"; then
source="$source $dirname.tar.gz::$url/archive/$ver.tar.gz"
# $source must be always in-sync with $sha512sums, so we have to
# add there source of a module that is disabled on the current arch.