aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-10-24 20:08:03 +0000
committerpsykose <alice@ayaya.dev>2022-10-24 22:08:03 +0200
commitbf97a208609657fa471303f61150c87185743353 (patch)
tree956fab7acbc87be805816a7b89547cf11384b82f
parent008107d8514022a27e868ed6fe2883e48cf52db5 (diff)
testing/asteroid-stopwatch: fix build, use samurai
-rw-r--r--testing/asteroid-stopwatch/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/asteroid-stopwatch/APKBUILD b/testing/asteroid-stopwatch/APKBUILD
index 8e4ce240097..1cfdd26b559 100644
--- a/testing/asteroid-stopwatch/APKBUILD
+++ b/testing/asteroid-stopwatch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=asteroid-stopwatch
pkgver=0_git20210517
-pkgrel=1
+pkgrel=2
_commit="fdc71d176c3d2c3e569c1d26998d4def12d9d1c3"
pkgdesc="Default stopwatch app for AsteroidOS"
url="https://github.com/AsteroidOS/asteroid-stopwatch"
@@ -15,13 +15,16 @@ makedepends="
qml-asteroid-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
+ "
+source="https://github.com/AsteroidOS/asteroid-stopwatch/archive/$_commit/asteroid-stopwatch-$_commit.tar.gz
+ $pkgname-new-ecm.patch::https://github.com/AsteroidOS/asteroid-stopwatch/commit/42bb9782aca55add824c95837caf33568c923dc2.patch
"
-source="https://github.com/AsteroidOS/asteroid-stopwatch/archive/$_commit/asteroid-stopwatch-$_commit.tar.gz"
options="!check" # No tests
builddir="$srcdir/$pkgname-$_commit"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
@@ -33,4 +36,5 @@ package() {
sha512sums="
c0037dedbeaf7b0a82c7a3d905a963617be14e7f988c776b310f6600deab5c175d66c32a11729001b871f57a56747afbffb17287ef295700c1edfdd688767f5d asteroid-stopwatch-fdc71d176c3d2c3e569c1d26998d4def12d9d1c3.tar.gz
+9090eaa9d501151d4257ff1a777cd1ebf8a9fbecdbda258b8ca86bfb65ec1b06502a074c3e70c164e32a7274c9ec401c7d49e9107869f67c9c9ae7db7d78917b asteroid-stopwatch-new-ecm.patch
"