aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-11-10 11:42:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-11-10 11:46:37 +0000
commitc09bb5ba64a108a4a9fc7eddb37f57713857d505 (patch)
tree5af9b74c9afb55cecfa7d7106f23a1e86a46bff5
parent169457fe57e6e63672acf6d853036869364fde42 (diff)
community/vdr: rebuild against libwebsockets 4.2
-rw-r--r--community/vdr/APKBUILD9
-rw-r--r--community/vdr/libwebsockets-4.1.patch16
2 files changed, 22 insertions, 3 deletions
diff --git a/community/vdr/APKBUILD b/community/vdr/APKBUILD
index a23898ebe81..69d0a60b37a 100644
--- a/community/vdr/APKBUILD
+++ b/community/vdr/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Taner Tas <taner76@gmail.com>
pkgname=vdr
pkgver=2.4.4
-pkgrel=1
+pkgrel=3
pkgdesc="Video Disk Recorder"
url="http://www.tvdr.de/"
arch="all !mips64" # ftbfs
@@ -74,7 +74,9 @@ source="ftp://ftp.tvdr.de/vdr/vdr-$pkgver.tar.bz2
Make.config
include-missing-limits.patch
streamdev_makefile.patch
- osd2web.patch"
+ osd2web.patch
+ libwebsockets-4.1.patch
+ "
prepare() {
cp -aP $srcdir/vdr-plugin-femon-${_femon_ver} $builddir/PLUGINS/src/femon
@@ -204,4 +206,5 @@ f47461445515e44f5cdb9c6d3b1bcae323bb83ba3de7c77a3be4d9ac99ed9e76ebe2ee720660c559
6b7102f609bf0272159753dca3b019482e97053a69a666fa0658f45d9d6dbd406070ac9320d127920c2e6d9b32f90b8b47d50d8490b3ce8575830938bb6b84e0 Make.config
7715ef27c820d9e7964dcc24dd12288f66fdf0a6db34d0da43cf6f16e2f815f23bd714654ffa9c3b7d28854bd1e0f7f201dcc5320f99556be92dd248b73bb86f include-missing-limits.patch
d65877bb0b2e983cf7b1c4b9e3ed8e4105c25f6ef4bb3c400255f4a30f7e177aa41d7a89871e2c4e2afae1447d6bbe26e79105d5ca20b8593ea49c35ae048952 streamdev_makefile.patch
-76eb4074a4a811da458e5ecf855925d295718228c9467c633054c3c6751494af3e06113a549f212f398485f947fb3a283fafe34c198967ab4e2d5c1bf5419495 osd2web.patch"
+76eb4074a4a811da458e5ecf855925d295718228c9467c633054c3c6751494af3e06113a549f212f398485f947fb3a283fafe34c198967ab4e2d5c1bf5419495 osd2web.patch
+c8abbf0f08af3f400f5d38677429a3735c4ac44ff5b4540ffa069c9498dd1f3f240c0c60f6a5040a62e56ddbb90e60ce0ae858266df58b20955c80c0014cc687 libwebsockets-4.1.patch"
diff --git a/community/vdr/libwebsockets-4.1.patch b/community/vdr/libwebsockets-4.1.patch
new file mode 100644
index 00000000000..c8eb8a45fb9
--- /dev/null
+++ b/community/vdr/libwebsockets-4.1.patch
@@ -0,0 +1,16 @@
+Add suport for building libwebsockets-4.1
+
+diff --git a/PLUGINS/src/osd2web/websock.c b/PLUGINS/src/osd2web/websock.c
+index 5df6975..8e5a7c3 100644
+--- a/PLUGINS/src/osd2web/websock.c
++++ b/PLUGINS/src/osd2web/websock.c
+@@ -79,7 +79,9 @@ int cWebSock::init(int aPort, int aTimeout)
+ info.protocols = protocols;
+ info.ssl_cert_filepath = certPath;
+ info.ssl_private_key_filepath = keyPath;
++#if LWS_LIBRARY_VERSION_NUMBER >= 2001000 && LWS_LIBRARY_VERSION_NUMBER < 4000000
+ info.ws_ping_pong_interval = timeout;
++#endif
+ info.gid = -1;
+ info.uid = -1;
+ info.options = 0;