aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2021-10-21 06:47:21 +0000
committerMilan P. Stanić <mps@arvanta.net>2021-10-22 06:31:17 +0000
commitc1075101a31c5989f237d0c155b3dabdeb899cea (patch)
treee25c1b3b5d06ab4562bc5bcceef49f49585ac63c
parent5d35a7dfa5d81c1790f693b47ead256203541073 (diff)
main/lxc: upgrade to 4.0.11
remove add-riscv64.patch, fixed upstream changed bashcomp() to install symlinks
-rw-r--r--main/lxc/APKBUILD10
-rw-r--r--main/lxc/add-riscv64.patch12
2 files changed, 4 insertions, 18 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 4be450f111d..b87904a0fef 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -2,9 +2,9 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lxc
-pkgver=4.0.10
+pkgver=4.0.11
_pkgver=${pkgver/_rc/.rc}
-pkgrel=2
+pkgrel=0
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
@@ -42,7 +42,6 @@ subpackages="
"
source="https://linuxcontainers.org/downloads/lxc/lxc-$_pkgver.tar.gz
- add-riscv64.patch
lxc.initd
lxc.confd
"
@@ -164,13 +163,12 @@ bashcomp() {
pkgdesc="Bash completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
- mv "$pkgdir"/etc/bash_completion.d/$pkgname "$subpkgdir"/usr/share/bash-completion/completions
+ mv "$pkgdir"/etc/bash_completion.d/* "$subpkgdir"/usr/share/bash-completion/completions
rmdir "$pkgdir"/etc/bash_completion.d
}
sha512sums="
-ec3ccf344a91b50b30985562c54ad93d2db2d29c24d31da8e3a69e801c8bd23c1560274c1850c39eb7e984940ba86d3ebae75db136320d6bbc5eb03bda4c5318 lxc-4.0.10.tar.gz
-728978eda7a016769fcde8828ae206926f560876cf658e7a1298b4841edf6763e90f7e692f277e5dc94ecbd885384ef4607c6cb24ca0f28aff719f24b8b62964 add-riscv64.patch
+23287e468da8939334f4261bfcbb52eadcbe5806bd97896db38c84eb42f32143dc17bb8b9bb7f7f88584b72056553c9edc33ddb693a345ecf88f3177573fa9c0 lxc-4.0.11.tar.gz
b74ffe7c3e8f193265a90ffeb6e5743b1212bc1416b898e5a7e59ddd7f06fc77dc34e2dcbb3614038ac6222a95e2b9beb9f03ab734c991837203ab626b1b091f lxc.initd
91de43db5369a9e10102933514d674e9c875218a1ff2910dd882e5b9c308f9e430deacb13d1d7e0b2ed1ef682d0bb035aa6f8a6738f54fa2ca3a05acce04e467 lxc.confd
"
diff --git a/main/lxc/add-riscv64.patch b/main/lxc/add-riscv64.patch
deleted file mode 100644
index 266ba6dd4ee..00000000000
--- a/main/lxc/add-riscv64.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/lxc/confile.c b/src/lxc/confile.c
-index 5d2c99f8a..279e52357 100644
---- a/src/lxc/confile.c
-+++ b/src/lxc/confile.c
-@@ -3214,6 +3214,7 @@ int lxc_config_parse_arch(const char *arch, signed long *persona)
- { "ppc64el", PER_LINUX },
- { "ppc64le", PER_LINUX },
- { "powerpc64", PER_LINUX },
-+ { "riscv64", PER_LINUX },
- { "s390x", PER_LINUX },
- { "x86_64", PER_LINUX },
- };