aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-07-19 10:16:21 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-07-19 10:17:17 +0000
commitc1244ee13ea9bebf29fe0a3ea31ad711b9ac7189 (patch)
tree8aef3dfec295b0e672263e152f09450fe26f5070
parent05de866650fc18d42bd49545c92a2b10e2f3c2fc (diff)
main/tevent: fix public header
sys/types.h is needed due to: /usr/include/tevent.h:1440:8: error: unknown type name 'pid_t' pid_t *pid, ^~~~~ /usr/include/tevent.h:1519:8: error: unknown type name 'pid_t' pid_t pid, ^~~~~
-rw-r--r--main/tevent/APKBUILD8
-rw-r--r--main/tevent/fix-public-header.patch13
2 files changed, 18 insertions, 3 deletions
diff --git a/main/tevent/APKBUILD b/main/tevent/APKBUILD
index a271d2b7f3d..a5fb4e432c4 100644
--- a/main/tevent/APKBUILD
+++ b/main/tevent/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tevent
pkgver=0.9.37
-pkgrel=0
+pkgrel=1
pkgdesc="The tevent library"
url="https://tevent.samba.org"
arch="all"
@@ -9,7 +9,8 @@ license="LGPL-3.0-or-later"
makedepends="libtirpc-dev python2-dev python3-dev talloc-dev"
replaces="samba"
subpackages="$pkgname-dev py2-$pkgname:_py2 py3-$pkgname:_py3"
-source="https://samba.org/ftp/tevent/tevent-$pkgver.tar.gz"
+source="https://samba.org/ftp/tevent/tevent-$pkgver.tar.gz
+ fix-public-header.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -55,4 +56,5 @@ _py3() {
mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
}
-sha512sums="5d4833403e1c2f2749f00a389e4757261a4f22cd3a67c906001b36a8b622cc68a38e86d4eb475848a2121ebba054a7e7dac7f486d9f2906a401c3cc97fb447f4 tevent-0.9.37.tar.gz"
+sha512sums="5d4833403e1c2f2749f00a389e4757261a4f22cd3a67c906001b36a8b622cc68a38e86d4eb475848a2121ebba054a7e7dac7f486d9f2906a401c3cc97fb447f4 tevent-0.9.37.tar.gz
+ee4cce8591dfe31288975596d8464b7cc160580715f88e4fd19b5ae7e1a831650b072954731f015f52d76600597faee894f0174b9e92d18dca9629f9d056230c fix-public-header.patch"
diff --git a/main/tevent/fix-public-header.patch b/main/tevent/fix-public-header.patch
new file mode 100644
index 00000000000..2b60347aba8
--- /dev/null
+++ b/main/tevent/fix-public-header.patch
@@ -0,0 +1,13 @@
+tevent.h needs sys/types.h for pid_t
+
+diff -ru tevent-0.9.37.orig/tevent.h tevent-0.9.37/tevent.h
+--- tevent-0.9.37.orig/tevent.h 2018-07-12 05:51:30.000000000 +0000
++++ tevent-0.9.37/tevent.h 2018-07-19 10:13:15.360128807 +0000
+@@ -31,6 +31,7 @@
+ #include <stdint.h>
+ #include <talloc.h>
+ #include <sys/time.h>
++#include <sys/types.h>
+ #include <stdbool.h>
+
+ struct tevent_context;