aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-08 09:24:47 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-08 09:24:59 +0000
commitc1530cb27b94a66f729381ac1c6fe75966f5bc60 (patch)
tree308224b4de303a786a3cd712e0213290a567de02
parent1c5670fe319e66107642d69f8ce3e3c719272470 (diff)
community/discount: build all shared and add check
-rw-r--r--community/discount/APKBUILD27
1 files changed, 21 insertions, 6 deletions
diff --git a/community/discount/APKBUILD b/community/discount/APKBUILD
index b9bd1a35559..ba509bebc0f 100644
--- a/community/discount/APKBUILD
+++ b/community/discount/APKBUILD
@@ -2,16 +2,18 @@
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=discount
pkgver=2.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="A Markdown to HTML translator written in C"
url="http://www.pell.portland.or.us/~orc/Code/discount/"
arch="all"
license="BSD"
depends="!markdown"
makedepends=""
-subpackages="$pkgname-dev $pkgname-doc"
+checkdepends="diffutils"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="http://www.pell.portland.or.us/~orc/Code/discount/$pkgname-$pkgver.tar.bz2
- configure.inc.patch"
+ configure.inc.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -21,13 +23,26 @@ build() {
--mandir=/usr/share/man \
--enable-all-features \
--with-fenced-code \
- || return 1
- make || return 1
+ --pkg-config \
+ --shared
+ make
+}
+
+check() {
+ msg "Running testsuites..."
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make PREFIX=/usr DESTDIR="$pkgdir" install install.man || return 1
+ make PREFIX=/usr DESTDIR="$pkgdir" install.everything
+ local bin; for bin in theme makepage mkd2html; do
+ mv "$pkgdir"/usr/bin/$bin \
+ "$pkgdir"/usr/bin/$pkgname-$bin
+ mv "$pkgdir"/usr/share/man/man1/$bin.1 \
+ "$pkgdir"/usr/share/man/man1/$pkgname-$bin.1
+ done
}
sha512sums="67d882c0a334592230332815c543458b3c916a950bf7983f8a468fbc9f61154b4023d4bf451b76639fcb3a076506b48118f192a8e21f2535b3f49c7f081bbdf3 discount-2.2.2.tar.bz2