aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-25 17:03:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 19:50:20 -0300
commitc165e41c47acc8c0639debe4e9a5688d48cc7472 (patch)
tree14cd8f894648cbaf875bf6858dd5b785c23564ff
parent8bc0dda2540bc1ed2c24c3d451c70d1de09048cf (diff)
community/py3-retrying: new aport
https://github.com/rholder/retrying/releases General purpose Python3 retrying library
-rw-r--r--community/py3-retrying/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-retrying/APKBUILD b/community/py3-retrying/APKBUILD
new file mode 100644
index 00000000000..700c5295242
--- /dev/null
+++ b/community/py3-retrying/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-retrying
+pkgver=1.3.3
+pkgrel=0
+pkgdesc="General purpose Python3 retrying library"
+url="https://github.com/rholder/retrying/releases"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rholder/retrying/archive/v$pkgver.tar.gz"
+builddir="$srcdir/retrying-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e053e62cb71b31573b89b8fffa706c3410794b5cced829582c373a09af78158f7a16948e6ce52078589cf7d8f5bba726c889180588a2628be343f242bc40c035 py3-retrying-1.3.3.tar.gz"