aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2021-01-08 08:44:23 +0000
committerLeo <thinkabit.ukim@gmail.com>2021-01-08 12:03:12 +0000
commitc168735a65f26026fcf9f64f4ee9cd81e4470265 (patch)
tree070e7d5f427c85fc7953310323abbb3042740a1d
parent034fa4b95be499610654a1f212f69b96bb74d154 (diff)
main/ell: upgrade to 0.36
remove ell-dhcp.patch and ell-pem.patch which are applied upstream
-rw-r--r--main/ell/APKBUILD8
-rw-r--r--main/ell/ell-dhcp.patch24
-rw-r--r--main/ell/ell-pem.patch43
3 files changed, 2 insertions, 73 deletions
diff --git a/main/ell/APKBUILD b/main/ell/APKBUILD
index e212771207d..5ae12aedb17 100644
--- a/main/ell/APKBUILD
+++ b/main/ell/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=ell
-pkgver=0.35
+pkgver=0.36
pkgrel=0
pkgdesc="Linux library for embedded development"
url="https://01.org/ell"
@@ -11,8 +11,6 @@ makedepends="glib-dev linux-headers"
checkdepends="dbus"
subpackages="$pkgname-dev"
source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/ell-$pkgver.tar.gz
- ell-dhcp.patch
- ell-pem.patch
"
build() {
@@ -35,6 +33,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="7676b9160e3b8e1bf88c5dede90761a3ee01e59028eccab127b48ee983cfbf73ba2177c453ed07e9d6a213e6ab02a1f9aed2ee88b6475da0a1a1a1e18f5fdabf ell-0.35.tar.gz
-cce268e76fcfed1a53b890c4c79f28f4570477963c4f795ef75940da233d9642a5574b608e6dcf449ffd4de468b923eafdebfe8cb4ef3e5bf55aecd1c32e28f0 ell-dhcp.patch
-c33bc3270c94c218280e80db857cdc99f757a6e51f3a5cdb5110b77c35faf80ce0418b8329b9d198d74be923e9da87fe53211c25b32541d0ea974fb5ccc2805d ell-pem.patch"
+sha512sums="8834ddfb430e33c5bed7c582a1a1d3360ff8f48c07a280dcd9b18778ba1b8ed950c54bfcb8bac9a427cd6e429a344326c5ddf7aa18e2df46e13606c922f9c1e2 ell-0.36.tar.gz"
diff --git a/main/ell/ell-dhcp.patch b/main/ell/ell-dhcp.patch
deleted file mode 100644
index df5888b9e0e..00000000000
--- a/main/ell/ell-dhcp.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Érico Rolim <erico.erc(a)gmail.com>
-
----
-
-I would prefer adding `#include <linux/types>` directly in
-dhcp-private.h, but this patch follows the current style.
-
- ell/dhcp-server.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/ell/dhcp-server.c b/ell/dhcp-server.c
-index c983ed4..144e83e 100644
---- a/ell/dhcp-server.c
-+++ b/ell/dhcp-server.c
-@@ -24,6 +24,7 @@
- #include <config.h>
- #endif
-
-+#include <linux/types.h>
- #include <net/ethernet.h>
- #include <sys/socket.h>
- #include <arpa/inet.h>
---
-2.29.2
diff --git a/main/ell/ell-pem.patch b/main/ell/ell-pem.patch
deleted file mode 100644
index c89e8f3f77d..00000000000
--- a/main/ell/ell-pem.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From: =?utf-8?q?=C3=89rico_Nogueira_=3Cericonr_at_disroot=2Eorg=3E?=
-To: ellatlists.01.org
-Subject: [BUG] ELL doesn't have a fallback for rawmemchr
-Date: Mon, 30 Nov 2020 13:49:47 -0300
-MIME-Version: 1.0
-Content-Transfer-Encoding: 8bit
-Content-Type: text/plain; charset=utf-8
-
-Hi!
-
-Building ELL 0.35 on a musl system fails, due to ell/pem.c using
-rawmemchr(), which is a glibc extension. Building IWD with internal
-ELL fails for the same reason.
-
-I see that IWD itself has src/missing.h with a fallback, but ELL lacks
-that.
-
-We are using the following patch to fix the build:
-
-diff --git a/ell/pem.c b/ell/pem.c
-index 790f2c2..237ae02 100644
---- a/ell/pem.c
-+++ b/ell/pem.c
-@@ -224,7 +224,7 @@ static uint8_t *pem_load_buffer(const void *buf, size_t=
- buf_len,
-
- /* Check that each header line has a key and a colon */
- while (start < end) {
-- const char *lf = rawmemchr(start, '\n');
-+ const char *lf = memchr(start, '\n', end - start);
- const char *colon = memchr(start, ':', lf - start);
-
- if (!colon)
-
---
-
-If ELL is willing to include a src/missing.h of their own, that would
-solve the issue, but avoiding rawmemchr() completely is also a
-possibility.
-
-Thanks,
-Érico
-