aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2021-06-07 18:12:03 +0300
committerprspkt <prspkt@protonmail.com>2021-06-07 18:13:26 +0300
commitc486d1a516a1c50a7914df6d3e1a0e83f860fad9 (patch)
treebb155dfb2a2d80d7f35ce384ee8aa54558c60841
parent440c0993ebe6bbcf46e2f733ce3eaebc8eb1d87c (diff)
testing/py3-cmd2: upgrade to 2.0.1
-rw-r--r--testing/py3-cmd2/APKBUILD8
-rw-r--r--testing/py3-cmd2/remove-setuptools_scm.patch12
2 files changed, 9 insertions, 11 deletions
diff --git a/testing/py3-cmd2/APKBUILD b/testing/py3-cmd2/APKBUILD
index 7f1698ab408..72ee016cea2 100644
--- a/testing/py3-cmd2/APKBUILD
+++ b/testing/py3-cmd2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: prspkt <prspkt@protonmail.com>
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-cmd2
-pkgver=1.5.0
+pkgver=2.0.1
pkgrel=0
pkgdesc="Tool for building interactive command line applications in Python"
url="https://github.com/python-cmd2/cmd2"
@@ -9,7 +9,7 @@ arch="noarch"
license="MIT"
depends="python3 py3-attrs py3-colorama py3-pyperclip py3-wcwidth"
makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-pytest-mock py3-pytest-xdist"
+checkdepends="py3-pytest py3-pytest-mock py3-pytest-xdist py3-pytest-cov"
source="https://files.pythonhosted.org/packages/source/c/cmd2/cmd2-$pkgver.tar.gz
remove-setuptools_scm.patch
"
@@ -33,6 +33,6 @@ package() {
}
sha512sums="
-ea7e26370e1f83dc95bd0db8a705ab8ea95935584123f4684e3b8debf23a37fbcadf2bc1634051eaddcaba92f2b22a0ab2582773630fab3d1482b4dc8a23acd6 cmd2-1.5.0.tar.gz
-53d9c2c95266696881f844a9ea13badcf198b955d7bca886310d2cef4bc35eda688eb56a2fb6197c75cd1dc2a649d67d45487bc2ee301408ddd4b760adf886ae remove-setuptools_scm.patch
+880c5f2d80f81a850b545052df2bf3efaae8f44deb30186119a2d94277da59cb027da5bf35b2bc106b90c87883c8eec1a869df65988ced1b6a0d0c7e236569bb cmd2-2.0.1.tar.gz
+9c9debe5c797b495f07e5c9ab7405fcd737eead8338315c31850088b2bb3d2d98aaf78b2c682344b57934a4a0e2da2eca49e8743f9c9e5d22d0b010d6f81985d remove-setuptools_scm.patch
"
diff --git a/testing/py3-cmd2/remove-setuptools_scm.patch b/testing/py3-cmd2/remove-setuptools_scm.patch
index 95cf3c7df89..708a898db3e 100644
--- a/testing/py3-cmd2/remove-setuptools_scm.patch
+++ b/testing/py3-cmd2/remove-setuptools_scm.patch
@@ -1,21 +1,19 @@
--- a/setup.py
+++ b/setup.py
-@@ -33,7 +33,7 @@
- Topic :: Software Development :: Libraries :: Python Modules
- """.splitlines()))) # noqa: E128
+@@ -40,7 +40,7 @@
+ )
+ ) # noqa: E128
-SETUP_REQUIRES = ['setuptools >= 34.4', 'setuptools_scm >= 3.0']
+SETUP_REQUIRES = ['setuptools >= 34.4']
INSTALL_REQUIRES = [
'attrs >= 16.3.0',
-@@ -77,9 +77,6 @@
+@@ -87,7 +87,6 @@
setup(
name="cmd2",
-- use_scm_version={
-- 'git_describe_command': 'git describe --dirty --tags --long --exclude plugin-*'
-- },
+- use_scm_version={'git_describe_command': 'git describe --dirty --tags --long --exclude plugin-*'},
description=DESCRIPTION,
long_description=LONG_DESCRIPTION,
long_description_content_type='text/markdown',