aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-07 22:30:22 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-07 22:32:42 +0000
commitc4fc46c7669fd80de4b09851a01df1b47eb83eb8 (patch)
tree828a3de6a29a5f4c239b805a9c1534c3b1a4b675
parent625aa15d09d4e3704ba949f7e86ea50b66cc1017 (diff)
community/deadbeef: Fix build on ppc64le
Currently deadbeef FTBFS on ppc64le due to two issues: 1) config.guess is outdated 2) deadbeef is not able to identify endianess on PPC machines. Fixing both of the issues to enable deadbeef to build on ppc64le.
-rw-r--r--community/deadbeef/APKBUILD15
-rw-r--r--community/deadbeef/ppc64le.patch25
2 files changed, 34 insertions, 6 deletions
diff --git a/community/deadbeef/APKBUILD b/community/deadbeef/APKBUILD
index f3b6c9a2b33..2ee85a319d4 100644
--- a/community/deadbeef/APKBUILD
+++ b/community/deadbeef/APKBUILD
@@ -16,10 +16,16 @@ makedepends="$depends_dev intltool gettext"
install=""
subpackages="$pkgname-dev $pkgname-lang $pkgname-doc"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname-$_ver.tar.bz2
- arm-buildfix.patch"
+ arm-buildfix.patch
+ ppc64le.patch"
builddir="${srcdir}/${pkgname}-$_ver"
+prepare() {
+ update_config_guess || return 1
+ default_prepare
+}
+
build() {
cd "$builddir"
CXXFLAGS="$CXXFLAGS -std=gnu++98" \
@@ -35,9 +41,6 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="f8f5353e7c201fce316f8b082ab408bb deadbeef-0.7.2.tar.bz2
-825397a941417e31cb28e6fc9202c3cf arm-buildfix.patch"
-sha256sums="8a63abdf00c2f37c33e018ae0b39d391873e037434074b84bb47381bf283c884 deadbeef-0.7.2.tar.bz2
-87b671ce5a8c2d0ef98c270ae1005648a4ae3e1298b408eb937974664def6a27 arm-buildfix.patch"
sha512sums="9ea61a3820d9d57f038b80652ce63bd87e6781259c0f58a93b70607b02e71debbf5598f4a06d607d3840a804c3b7fc5039a4c4b0a8bb01e8e5107bba3f0bd980 deadbeef-0.7.2.tar.bz2
-57e25e3478b5516f0ebc34fa561c619bdca4cdf7e9f6dc1d81317c972b10bd073a4a761dfc2327047fd56433e79ff57bf501c9cfe77079c450b46f5a0315555b arm-buildfix.patch"
+57e25e3478b5516f0ebc34fa561c619bdca4cdf7e9f6dc1d81317c972b10bd073a4a761dfc2327047fd56433e79ff57bf501c9cfe77079c450b46f5a0315555b arm-buildfix.patch
+682629f5b677df106083d7187a01a832b92c6474f5a0a2e66e9aac36248aeb8c136fe8b13469e319df08e3eac634330aa62a2dea73f58a524254a6b3d1e92e09 ppc64le.patch"
diff --git a/community/deadbeef/ppc64le.patch b/community/deadbeef/ppc64le.patch
new file mode 100644
index 00000000000..d8106c77a7a
--- /dev/null
+++ b/community/deadbeef/ppc64le.patch
@@ -0,0 +1,25 @@
+Author: Breno Leitao <breno.leitao@gmail.com>
+Date: Fri Apr 7 22:00:01 2017 +0000
+
+ blargg_endian: Fails to build on non-x86 with musl
+
+ Currently blargg_endian fails to detect endiness on non-x86, as ppc64le,
+ when not using glibc.
+
+ In my case, I am using musl on ppc64le, and deadbeef fails to compile
+ because the endianess is not known.
+
+ This patch defines BLARGG_LITTLE_ENDIAN if the system is ppc64le.
+
+--- a/plugins/gme/game-music-emu-0.6pre/gme/blargg_endian.h
++++ b/plugins/gme/game-music-emu-0.6pre/gme/blargg_endian.h
+@@ -16,6 +16,9 @@
+ defined (__POWERPC__) || defined (__powerc)
+ #define BLARGG_CPU_POWERPC 1
+ #define BLARGG_CPU_RISC 1
++ #if defined(__LITTLE_ENDIAN__)
++ #define BLARGG_LITTLE_ENDIAN 1
++ #endif
+ #endif
+
+ // BLARGG_BIG_ENDIAN, BLARGG_LITTLE_ENDIAN: Determined automatically, otherwise only