aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:25:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:41:29 +0200
commitc5476139ab838bbaea8b7a1ca8ef24650ebc608b (patch)
treef1b207f455131abd3c65158afaf6f9fbaba93100
parentdcae868bf8a795b49de5ce479ac7988239ed9722 (diff)
testing/ocaml-ppx_tools_versioned: upgrade to 5.2
-rw-r--r--testing/ocaml-ppx_tools_versioned/APKBUILD39
1 files changed, 25 insertions, 14 deletions
diff --git a/testing/ocaml-ppx_tools_versioned/APKBUILD b/testing/ocaml-ppx_tools_versioned/APKBUILD
index 7ac9f10fb92..e438acc06a1 100644
--- a/testing/ocaml-ppx_tools_versioned/APKBUILD
+++ b/testing/ocaml-ppx_tools_versioned/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-ppx_tools_versioned
_pkgname=ppx_tools_versioned
-pkgver=5.1
-pkgrel=3
+pkgver=5.2
+pkgrel=0
pkgdesc="Tools for authors of ppx rewriters"
url="https://github.com/ocaml-ppx/ppx_tools_versioned"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
license="MIT"
depends="ocaml-runtime ocaml-migrate-parsetree"
-makedepends="ocaml ocaml-compiler-libs ocaml-findlib ocaml-migrate-parsetree-dev"
+makedepends="dune ocaml ocaml-compiler-libs ocaml-findlib
+ ocaml-migrate-parsetree-dev opam"
# textrels needed for ppc64le
# no tests provided
options="textrels !check"
@@ -19,29 +20,39 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- make
+ jbuilder build @install
}
package() {
cd "$builddir"
- export OCAMLFIND_DESTDIR="$pkgdir/usr/lib/ocaml"
- mkdir -p "$OCAMLFIND_DESTDIR"
- make install
+ mkdir -p "$pkgdir"/usr/lib/ocaml
+ jbuilder install \
+ --destdir="$pkgdir"/usr \
+ --libdir="$pkgdir"/usr/lib/ocaml
- # Remove annotation files.
- rm -Rf "$pkgdir"/usr/lib/ocaml/$_pkgname*/*.cmt*
+ # There's just a readme and changelog.
+ rm -Rf "$pkgdir"/usr/doc
+
+ # Remove annotation files and sources.
+ cd "$pkgdir"/usr/lib/ocaml/$_pkgname
+ rm -f *.cmt* */*.cmt* *.ml */*.ml
}
dev() {
default_dev
depends="$pkgname=$pkgver-r$pkgrel"
- local sitelib="usr/lib/ocaml/$_pkgname"
- cd "$pkgdir"/$sitelib
+ cd "$pkgdir"
- mkdir -p "$subpkgdir"/$sitelib
- mv *.cmx *.cmxa "$subpkgdir"/$sitelib/
+ local path; for path in $(find usr/lib/ocaml/$_pkgname \
+ -name '*.cmx' \
+ -o -name '*.cmxa' \
+ -o -name '*.mli')
+ do
+ mkdir -p "${path%/*}"
+ mv "$path" "$subpkgdir"/${path%/*}/
+ done
}
-sha512sums="b3412dc204ed3aed42c99f0e900108f5003a96e39b3a78df279c5e9512f14ceb77dde2ff2d552fb0386d43a5f276feca3bd306286a860e13680c94d39421125d ocaml-ppx_tools_versioned-5.1.tar.gz"
+sha512sums="1efb7fc24f0b909d948aca53abee6e0613aaf101e6cf914772557ec00c879890d50b9c6e232f55a54381eab164a40d796d953b4992ef40a6e9141abd2b409cba ocaml-ppx_tools_versioned-5.2.tar.gz"