aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-06-15 05:55:34 +0000
committerpsykose <alice@ayaya.dev>2023-06-15 07:58:01 +0200
commitc555281415d250c1dca370094302bfdc19f4628f (patch)
treef481ed5bc1451cfadded254b056f80f6d24bf6ea
parentfdd005ef114636fb06dc997f062aea5a7576326b (diff)
testing/gpscorrelate: upgrade to 2.0_git20230605
-rw-r--r--testing/gpscorrelate/APKBUILD13
-rw-r--r--testing/gpscorrelate/exiv2-0.28.patch87
2 files changed, 95 insertions, 5 deletions
diff --git a/testing/gpscorrelate/APKBUILD b/testing/gpscorrelate/APKBUILD
index 46d3f78afa4..176d0d5af75 100644
--- a/testing/gpscorrelate/APKBUILD
+++ b/testing/gpscorrelate/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Saijin-Naib <Saijin-Naib_package-maintenance@outlook.com>
# Maintainer: Saijin-Naib <Saijin-Naib_package-maintenance@outlook.com>
pkgname=gpscorrelate
-pkgver=2.0_git20230303
-_githash=526c080940d0a375c361ea599bf4cc793e52f2db
+pkgver=2.0_git20230605
+_githash=fd556bc0cf9341511036f0535e76a50c1f50dcec
pkgrel=0
pkgdesc="Program to match GPS tracks to photographs and store the matches in EXIF"
url="https://dfandrich.github.io/gpscorrelate/"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
makedepends="
desktop-file-utils
exiv2-dev
@@ -19,7 +19,9 @@ makedepends="
libxslt-dev
"
subpackages="$pkgname-cli $pkgname-doc $pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/dfandrich/gpscorrelate/archive/$_githash.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dfandrich/gpscorrelate/archive/$_githash.tar.gz
+ exiv2-0.28.patch
+ "
builddir="$srcdir/$pkgname-$_githash"
build() {
@@ -40,5 +42,6 @@ cli() {
}
sha512sums="
-f2c44ee4a8a9f9116affb351bc296583146a6ad010f46a3358386ad86420a243899461c4852345dabc14be7ec089ca9a3bd3f90c87011dca8b60fe85755ff642 gpscorrelate-2.0_git20230303.tar.gz
+6baaf62180aaa86a0d0989808e206030d0d313428c6e51aaabb9b5ded7ecc836a91a8f9ac28b5b04f0a8f2f2d61fe53fc8d8a7d55da20d7f04c2a18ac875ef86 gpscorrelate-2.0_git20230605.tar.gz
+15ff7a1b48ac65c8a94928bf269a5c077b198a1c246a1c07a0b2749c7b228be13613e4816538542cb8e8dd6c29a3738ffe3cf67ea00e8075272f6de4229d7d5b exiv2-0.28.patch
"
diff --git a/testing/gpscorrelate/exiv2-0.28.patch b/testing/gpscorrelate/exiv2-0.28.patch
new file mode 100644
index 00000000000..48eddd24637
--- /dev/null
+++ b/testing/gpscorrelate/exiv2-0.28.patch
@@ -0,0 +1,87 @@
+Patch-Source: https://gitlab.archlinux.org/archlinux/packaging/packages/gpscorrelate/-/blob/9d84f5a7ec16d73970ab89924a106652348b7063/exiv2-0.28.patch
+--
+diff --git a/exif-gps.cpp b/exif-gps.cpp
+index d464d62..8c91cf4 100644
+--- a/exif-gps.cpp
++++ b/exif-gps.cpp
+@@ -97,7 +97,7 @@ int main(int argc, char* argv[])
+ char* ReadExifDate(const char* File, int* IncludesGPS)
+ {
+ // Open and read the file.
+- Exiv2::Image::AutoPtr Image;
++ Exiv2::Image::UniquePtr Image;
+
+ try {
+ Image = Exiv2::ImageFactory::open(File);
+@@ -154,7 +154,7 @@ char* ReadExifData(const char* File, double* Lat, double* Long, double* Elev, in
+ // much more data than the last, specifically
+ // for display purposes. For the GUI version.
+ // Open and read the file.
+- Exiv2::Image::AutoPtr Image;
++ Exiv2::Image::UniquePtr Image;
+
+ try {
+ Image = Exiv2::ImageFactory::open(File);
+@@ -273,7 +273,7 @@ char* ReadExifData(const char* File, double* Lat, double* Long, double* Elev, in
+
+ // Is the altitude below sea level? If so, negate the value.
+ GPSData = ExifRead["Exif.GPSInfo.GPSAltitudeRef"];
+- if (GPSData.count() >= 1 && GPSData.toLong() == 1)
++ if (GPSData.count() >= 1 && GPSData.toUint32() == 1)
+ {
+ // Negate the elevation.
+ *Elev = -*Elev;
+@@ -292,7 +292,7 @@ char* ReadGPSTimestamp(const char* File, char* DateStamp, char* TimeStamp, int*
+ // much more data than the last, specifically
+ // for display purposes. For the GUI version.
+ // Open and read the file.
+- Exiv2::Image::AutoPtr Image;
++ Exiv2::Image::UniquePtr Image;
+
+ try {
+ Image = Exiv2::ImageFactory::open(File);
+@@ -463,7 +463,7 @@ int WriteGPSData(const char* File, const struct GPSPoint* Point,
+ struct utimbuf utb;
+ if (NoChangeMtime)
+ stat(File, &statbuf);
+- Exiv2::Image::AutoPtr Image;
++ Exiv2::Image::UniquePtr Image;
+
+ try {
+ Image = Exiv2::ImageFactory::open(File);
+@@ -493,7 +493,7 @@ int WriteGPSData(const char* File, const struct GPSPoint* Point,
+ // Do all the easy constant ones first.
+ // GPSVersionID tag: standard says it should be four bytes: 02 02 00 00
+ // (and, must be present).
+- Exiv2::Value::AutoPtr Value = Exiv2::Value::create(Exiv2::unsignedByte);
++ Exiv2::Value::UniquePtr Value = Exiv2::Value::create(Exiv2::unsignedByte);
+ Value->read("2 2 0 0");
+ replace(ExifToWrite, Exiv2::ExifKey("Exif.GPSInfo.GPSVersionID"), Value.get());
+ // Datum: the datum of the measured data. The default is WGS-84.
+@@ -643,7 +643,7 @@ int WriteFixedDatestamp(const char* File, time_t Time)
+ struct utimbuf utb;
+ stat(File, &statbuf);
+
+- Exiv2::Image::AutoPtr Image;
++ Exiv2::Image::UniquePtr Image;
+
+ try {
+ Image = Exiv2::ImageFactory::open(File);
+@@ -672,7 +672,7 @@ int WriteFixedDatestamp(const char* File, time_t Time)
+ ExifToWrite.erase(ExifToWrite.findKey(Exiv2::ExifKey("Exif.GPSInfo.GPSDateStamp")));
+ ExifToWrite["Exif.GPSInfo.GPSDateStamp"] = ScratchBuf;
+
+- Exiv2::Value::AutoPtr Value = Exiv2::Value::create(Exiv2::unsignedRational);
++ Exiv2::Value::UniquePtr Value = Exiv2::Value::create(Exiv2::unsignedRational);
+ snprintf(ScratchBuf, sizeof(ScratchBuf), "%d/1 %d/1 %d/1",
+ TimeStamp.tm_hour, TimeStamp.tm_min,
+ TimeStamp.tm_sec);
+@@ -705,7 +705,7 @@ int RemoveGPSExif(const char* File, int NoChangeMtime, int NoWriteExif)
+ stat(File, &statbuf);
+
+ // Open the file and start reading.
+- Exiv2::Image::AutoPtr Image;
++ Exiv2::Image::UniquePtr Image;
+
+ try {
+ Image = Exiv2::ImageFactory::open(File);