aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-25 23:54:09 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-28 15:13:38 +0000
commitc73da50396ddd573007f9e4bbfd83f69a6440a31 (patch)
tree99f116eb5ace7ff1dec2809dfb24c508a86805e8
parentf87a922ec940b82189c75035b35c7d8dfe568e2b (diff)
main/ndctl: upgrade to 65
-rw-r--r--main/ndctl/APKBUILD15
-rw-r--r--main/ndctl/fix-includes.patch10
2 files changed, 7 insertions, 18 deletions
diff --git a/main/ndctl/APKBUILD b/main/ndctl/APKBUILD
index d0abea40ee5..69e61505bf3 100644
--- a/main/ndctl/APKBUILD
+++ b/main/ndctl/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Breno Leitao <breno.leitao@gmail.com>
pkgname=ndctl
-pkgver=61.2
+pkgver=65
pkgrel=0
pkgdesc="Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel"
url="https://github.com/pmem/ndctl"
@@ -8,12 +8,11 @@ arch="all"
license="GPL-2.0-only LGPL-2.1-only"
depends="libuuid json-c kmod"
makedepends="autoconf automake libtool asciidoc xmlto kmod-dev
- eudev-dev util-linux-dev json-c-dev linux-headers"
+ eudev-dev util-linux-dev json-c-dev linux-headers asciidoctor
+ bash-completion keyutils-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs
$pkgname-bash-completion:bashcomp:noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/pmem/$pkgname/archive/v$pkgver.tar.gz
- fix-includes.patch"
-builddir="$srcdir"/$pkgname-$pkgver
+source="$pkgname-$pkgver.tar.gz::https://github.com/pmem/$pkgname/archive/v$pkgver.tar.gz"
options="!check" # tests require building & loading the nfit_test.ko kernel module
prepare() {
@@ -30,7 +29,8 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --without-systemd
make
}
@@ -48,5 +48,4 @@ bashcomp() {
mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
}
-sha512sums="da231a61654b0f863c8cac8d70b166a5a60df4be86ed74e1e8fb3a23b4692483200075f0606244720f1b919891c00eb3ae9b49c48662213bc08601f0fe11008b ndctl-61.2.tar.gz
-04f4509cd634dc6b40108012928ac8cc44fc4ce3a27c866ba7eb4124c9c1e9a123fe8aaf9a8b5e9513692a2e623ab1ab13f0eaaaa6537ee2bf0871c1d90c83ab fix-includes.patch"
+sha512sums="3e468d0c87a27c45f25cc8e165bab5e2914748a3a755a6393b35655178b91a6a9d6fbb16c3ff06df5463caa4fe29432f53130b30ba5cda4faf165d72f382db46 ndctl-65.tar.gz"
diff --git a/main/ndctl/fix-includes.patch b/main/ndctl/fix-includes.patch
deleted file mode 100644
index 6ae4173072e..00000000000
--- a/main/ndctl/fix-includes.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/util/strbuf.h
-+++ b/util/strbuf.h
-@@ -17,6 +17,7 @@
- #define __NDCTL_STRBUF_H
- #include <string.h>
- #include <assert.h>
-+#include <sys/types.h>
-
- /*
- * Strbuf's can be use in many ways: as a byte array, or to store arbitrary