aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-11 20:33:30 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-11 20:34:20 +0200
commitc819bb5c7ae34774411ef3615d025cacd2f760a3 (patch)
tree4209bc592e026b08118fba65f1729697ccbdfe0b
parent8070f091c992f61518740c9c5558b3d2ed2704af (diff)
main/uwsgi: fix depends for plugins with requirements
-rw-r--r--main/uwsgi/APKBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index 8f111aaad69..f12deab7c01 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uwsgi
pkgver=2.0.14
-pkgrel=8
+pkgrel=9
pkgdesc="uWSGI application container server"
url="http://projects.unbit.it/uwsgi/"
arch="all"
@@ -189,6 +189,19 @@ _plugin() {
depends="uwsgi"
cd "$builddir"
+
+ local requires=$(sed '$a print(" ".join(REQUIRES))' \
+ plugins/$name/uwsgiplugin.py 2>/dev/null | python3 2>/dev/null)
+
+ local req; for req in $requires; do
+ if echo "$_plugins" | grep -qw "$req"; then
+ depends="$depends $pkgname-$req"
+ else
+ error "There's no subpackage for requirement $req!"
+ return 1
+ fi
+ done
+
install -m 755 -D ${name}_plugin.so \
"$subpkgdir"/usr/lib/uwsgi/${name}_plugin.so || return 1
}