aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-29 13:13:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-29 16:36:57 +0000
commitc8322a517e72c0075d81bac674ee58419c5b7956 (patch)
tree6653939e34259d626e415802bc93699a5b272bf4
parent08226cbcb168912daf84d0049ef0a6bc7f31c544 (diff)
community/elogind: fix version number
246.9.1 breaks sdbus-cpp
-rw-r--r--community/elogind/APKBUILD6
-rw-r--r--community/elogind/fix-version.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/community/elogind/APKBUILD b/community/elogind/APKBUILD
index da6ddb65c72..f523b02d7b2 100644
--- a/community/elogind/APKBUILD
+++ b/community/elogind/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=elogind
pkgver=246.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="Standalone fork of systemd's elogind"
url="https://github.com/elogind/elogind"
arch="all"
@@ -40,6 +40,7 @@ subpackages="
source="https://github.com/elogind/elogind/archive/v$pkgver/elogind-v$pkgver.tar.gz
elogind.initd
fix-mips-detection.patch
+ fix-version.patch
"
build() {
@@ -96,4 +97,5 @@ bashcomp() {
sha512sums="b409568630ac20c1e984d9389237533e67ce4ad0fe0e0d47ad3fd943e579971412bcbdb922f2929bc5e9f26198647d3436beadbde0bfed4ae730107611a69e48 elogind-v246.9.1.tar.gz
e73738488e78af099fdbb7c93a411a3e8d69080a93f89c245cb8c6de5fe4cb7fe724687d19e21eb6be52ccc795ec200d9c6e499efb1afd2b27467f7f541a7dd1 elogind.initd
-0fda4318afc6db9c9d00121ed4f8267286e692cca04acf4c1006fab99267cdd6228e1d176293f99db043384ae6fa192fc8109a365bf221dda7f2c4177d104820 fix-mips-detection.patch"
+0fda4318afc6db9c9d00121ed4f8267286e692cca04acf4c1006fab99267cdd6228e1d176293f99db043384ae6fa192fc8109a365bf221dda7f2c4177d104820 fix-mips-detection.patch
+87781120d496c4a1bebbac860030766428e6f6ad4a9830640190fc414c3e6ff245e8966052690c86b26ded702a17278cfc2ca45d1b6105cb97e602d77d12d5f5 fix-version.patch"
diff --git a/community/elogind/fix-version.patch b/community/elogind/fix-version.patch
new file mode 100644
index 00000000000..4a070b35466
--- /dev/null
+++ b/community/elogind/fix-version.patch
@@ -0,0 +1,13 @@
+diff --git a/meson.build b/meson.build
+index a795b99..212f70b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: LGPL-2.1+
+
+ project('elogind', 'c',
+- version : '246.9.1',
++ version : '246',
+ license : 'LGPLv2+',
+ default_options: [
+ 'c_std=gnu99',