aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-01 22:24:47 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-09 20:05:23 +0000
commitc8cc1f5195e98da3eaa58b1265a5e1c5845badd3 (patch)
tree6054bf0c518516b42eb60f8c3a500fb37920a9ef
parent4625d047b14e841a4222e46ed0bbf6123ae8e148 (diff)
testing/mycroft-skill-date-time: new aport
-rw-r--r--testing/mycroft-skill-date-time/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/mycroft-skill-date-time/APKBUILD b/testing/mycroft-skill-date-time/APKBUILD
new file mode 100644
index 00000000000..b097cf80ce0
--- /dev/null
+++ b/testing/mycroft-skill-date-time/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=mycroft-skill-date-time
+pkgver=20.02_git20200503
+pkgrel=0
+_commit="1b3d4dfc4500d16670e1e412546a8956c162f82d"
+pkgdesc="Mycroft AI official Date and Time Skill, providing the current time, date and day of week for cities around the world"
+url="https://mycroft.ai/skills"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-tz py3-tzlocal py3-astral py3-holidays"
+source="https://github.com/mycroftai/skill-date-time/archive/$_commit/skills-date-time-$_commit.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/skill-date-time-$_commit"
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/mycroft/skills/mycroft-date-time.mycroftai
+ cp -r ./* "$pkgdir"/usr/share/mycroft/skills/mycroft-date-time.mycroftai/
+}
+
+sha512sums="82b77d4cefe2680d44ade86f66a5db0a709d09b21c3695845e97df2bdfb06387d33e2ae343a47fae705546b7d65241e429e1b36bc867acc6e7c11e17267c7841 skills-date-time-1b3d4dfc4500d16670e1e412546a8956c162f82d.tar.gz"