aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 03:35:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 07:58:06 -0300
commitc8f2b570d0cfe708e200e498145c1b53812fa23b (patch)
tree93d3d96a835dbff76b094e60b3041ffa9f6508bc
parent64931a5538bc07db9e26f4c93e09292f7a0901b9 (diff)
community/lua-mmdb: enable s390x luajit
-rw-r--r--community/lua-mmdb/APKBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/community/lua-mmdb/APKBUILD b/community/lua-mmdb/APKBUILD
index c80c5f8c9bc..779dc759233 100644
--- a/community/lua-mmdb/APKBUILD
+++ b/community/lua-mmdb/APKBUILD
@@ -11,19 +11,12 @@ url="https://github.com/daurnimator/mmdblua"
arch="noarch"
license="MIT"
depends="lua"
-checkdepends="lua-busted lua5.1-compat53 lua5.2-compat53"
-subpackages=""
-source="https://github.com/daurnimator/mmdblua/archive/v$pkgver/$pkgname-$pkgver.tar.gz
+checkdepends="lua-busted lua5.1-compat53 lua5.2-compat53 luajit"
+source="https://github.com/daurnimator/mmdblua/archive/v$pkgver/lua-mmdb-$pkgver.tar.gz
https://github.com/maxmind/MaxMind-DB/archive/$_maxmind_gitrev/MaxMind-DB-$_maxmind_gitrev.tar.gz
"
builddir="$srcdir/$_rockname-$pkgver"
-case "$CARCH" in
- # luajit is not available for s390x
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
@@ -38,7 +31,7 @@ prepare() {
}
check() {
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions jit; do
msg "Testing on lua$lver"
LUA_PATH='?/init.lua;;' lua$lver /usr/bin/busted
done