aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-08-16 10:47:19 +0000
committeralice <alice@ayaya.dev>2022-08-16 10:50:07 +0000
commitc9834f46f98b0a68b5c56f3c5418b91ae9f7d63f (patch)
tree36176a27c0a5a3110265034afa587de16d4e33c3
parent00dd63de61c633e0ca4353c2a3024b838eb9783b (diff)
downloadaports-c9834f46f98b0a68b5c56f3c5418b91ae9f7d63f.tar.gz
aports-c9834f46f98b0a68b5c56f3c5418b91ae9f7d63f.tar.bz2
aports-c9834f46f98b0a68b5c56f3c5418b91ae9f7d63f.tar.xz
community/gnu-libiconv: upgrade to 1.17
-rw-r--r--community/gnu-libiconv/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/gnu-libiconv/APKBUILD b/community/gnu-libiconv/APKBUILD
index 10ca8bf11b..3ea65a24b6 100644
--- a/community/gnu-libiconv/APKBUILD
+++ b/community/gnu-libiconv/APKBUILD
@@ -1,15 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnu-libiconv
-pkgver=1.16
+pkgver=1.17
pkgrel=0
pkgdesc="GNU charset conversion library for libc which doesn't implement it"
url="https://www.gnu.org/software/libiconv"
arch="all"
license="LGPL-2.1-or-later"
-options="!check" # fails to detect correct libiconv.so.2
+depends_dev="$pkgname=$pkgver-r$pkgrel"
source="https://ftp.gnu.org/pub/gnu/libiconv/libiconv-$pkgver.tar.gz"
-subpackages="$pkgname-doc $pkgname-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
builddir="$srcdir"/libiconv-$pkgver
+options="!check" # fails to detect correct libiconv.so.2
build() {
./configure \
@@ -34,6 +35,8 @@ check() {
}
package() {
+ # iconv util
+ license="GPL-3.0-or-later"
make DESTDIR="$pkgdir/" install
# move headers so they dont clash with libc headers
@@ -43,4 +46,6 @@ package() {
}
-sha512sums="365dac0b34b4255a0066e8033a8b3db4bdb94b9b57a9dca17ebf2d779139fe935caf51a465d17fd8ae229ec4b926f3f7025264f37243432075e5583925bb77b7 libiconv-1.16.tar.gz"
+sha512sums="
+18a09de2d026da4f2d8b858517b0f26d853b21179cf4fa9a41070b2d140030ad9525637dc4f34fc7f27abca8acdc84c6751dfb1d426e78bf92af4040603ced86 libiconv-1.17.tar.gz
+"