aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Marz <main@lmarz.org>2021-05-01 16:29:59 +0200
committerLeo <thinkabit.ukim@gmail.com>2021-05-12 16:02:12 +0000
commitc9dac75b14da80202ffb2582beb4b43f8ec17f43 (patch)
tree4047fb5c833b4165b7e6991dc5cc881f42a44c17
parentae08dd61a3d83ed0d95da6bf776cf63eb5faed13 (diff)
testing/opensubdiv: upgrade to 3.4.4
-rw-r--r--testing/opensubdiv/0001-remove-rpath.patch36
-rw-r--r--testing/opensubdiv/APKBUILD64
2 files changed, 71 insertions, 29 deletions
diff --git a/testing/opensubdiv/0001-remove-rpath.patch b/testing/opensubdiv/0001-remove-rpath.patch
new file mode 100644
index 00000000000..6eda0fea899
--- /dev/null
+++ b/testing/opensubdiv/0001-remove-rpath.patch
@@ -0,0 +1,36 @@
+From 1d841c8e5ab36b932d9e51a1e871539451786632 Mon Sep 17 00:00:00 2001
+From: Leon Marz <main@lmarz.org>
+Date: Sat, 1 May 2021 16:21:51 +0200
+Subject: [PATCH] remove rpath
+
+---
+ CMakeLists.txt | 13 -------------
+ 1 file changed, 13 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 359114e..eebf833 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -140,19 +140,6 @@ elseif(${CMAKE_CXX_COMPILER_ID} MATCHES "Intel")
+ set(CMAKE_COMPILER_IS_ICC 1)
+ endif()
+
+-
+-if (NOT CMAKE_COMPILER_IS_ICC)
+- # Currently icc has a bug that asserts when linking rpaths containing long
+- # sequences of ':' that this command causes. The consequence is that examples
+- # built and installed using icc will not have an rpath pointing to the built
+- # OSD library which they depend on and will have to set LD_LIBRARY_PATH instead.
+- list(APPEND CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+-endif()
+-
+-# add the automatically determined parts of the RPATH
+-# which point to directories outside the build tree to the install RPATH
+-SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+-
+ # ensure that ARC is shown as enabled in the Xcode UI
+ if(CMAKE_GENERATOR STREQUAL "Xcode")
+ set (CMAKE_XCODE_ATTRIBUTE_CLANG_ENABLE_OBJC_ARC "YES")
+--
+2.31.1
+
diff --git a/testing/opensubdiv/APKBUILD b/testing/opensubdiv/APKBUILD
index 16f261c0b0b..962a2d56902 100644
--- a/testing/opensubdiv/APKBUILD
+++ b/testing/opensubdiv/APKBUILD
@@ -1,61 +1,67 @@
# Contributor: Mark Riedesel <mark@klowner.com>
+# Contributor: Leon Marz <main@lmarz.org>
# Maintainer: Mark Riedesel <mark@klowner.com>
pkgname=opensubdiv
-_pkgname=OpenSubdiv
-pkgver=3.4.3
+pkgver=3.4.4
_pkgver=${pkgver//./_}
pkgrel=0
pkgdesc="An Open-Source subdivision surface library"
url="http://graphics.pixar.com/opensubdiv"
-arch="all"
+arch="all !s390x !mips !mips64" # ptex isn't available on these arches
license="Apache-2.0"
-makedepends="cmake glew-dev glfw-dev doxygen py3-docutils
- libxcursor-dev libxrandr-dev"
+makedepends="cmake
+ doxygen
+ glfw-dev
+ libtbb-dev
+ libxcursor-dev
+ libxi-dev
+ libxrandr-dev
+ ptex-dev
+ ptex
+ py3-docutils
+ zlib-dev
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-tutorials $pkgname-tools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/PixarAnimationStudios/$_pkgname/archive/v$_pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$_pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v$_pkgver.tar.gz
+ 0001-remove-rpath.patch
+ "
+builddir="$srcdir/OpenSubdiv-$_pkgver"
build() {
- mkdir -p "$builddir"/build
- cd "$builddir"/build
-
- cmake .. \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_SKIP_RPATH=TRUE \
- -DCMAKE_C_FLAGS="$CFLAGS" \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DNO_TBB=TRUE \
- -DNO_PTEX=TRUE \
- -DNO_MAYA=TRUE \
- -DNO_CUDA=TRUE \
- -DNO_OPENCL=TRUE
- make
+ -DNO_CLEW=ON \
+ -DNO_CUDA=ON \
+ -DNO_GLTESTS=ON
+ cmake --build build
+}
+
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
tutorials() {
pkgdesc="$pkgdesc (tutorials)"
depends="$pkgname"
- cd "$pkgdir"
-
mkdir -p "$subpkgdir"/usr/bin/
- local tut; for tut in ./usr/bin/tutorials/*; do
+ local tut; for tut in "$pkgdir"/usr/bin/tutorials/*; do
mv $tut "$subpkgdir"/usr/bin/opensubdiv_${tut##*/}
done
- rmdir ./usr/bin/tutorials
+ rmdir "$pkgdir"/usr/bin/tutorials
}
tools() {
pkgdesc="$pkgdesc (tools)"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+ amove usr/bin
}
-sha512sums="44fd1361d9e7f48c3fa84f3420ed34743571220602aefb082a42f769ca5b8e9ac21907ce8714f6e3a2caadd75adae03c535a1949a8e6450dfea9ae7a2247cfc2 opensubdiv-3.4.3.tar.gz"
+sha512sums="fc8f28b79347015c8991150535c1339e695d96947c72fadd4fa27b546a0813c1125cd175ee03bed5aacdb3609f74c4e526ef70103d1195ba9f7df041e73ea9fb opensubdiv-3.4.4.tar.gz
+2b00a32cc6708fcd0cfe54d5b4895f64f8295044fdfa1c5e7adcddb630fe6cb3564330a9ebd6b801e7469befc45a26f48aa18620f3b7cf5a27272d54cda442c0 0001-remove-rpath.patch"