aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-22 18:03:08 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-22 18:19:17 +0200
commitcaa021b32a79a347a6b11a1daa97c19aeaf5a6d8 (patch)
treecd89df95cb92d9f415c874cfcaa0c32791294e51
parent5d4ec59857470a951f74e3efded955a18e8ca12c (diff)
community/searx: fix startup with py3-werkzeug>=1.0
See https://github.com/asciimoo/searx/pull/1831 ref !6420
-rw-r--r--community/searx/1831.patch27
-rw-r--r--community/searx/APKBUILD10
-rw-r--r--community/searx/relax-dependencies.patch2
3 files changed, 35 insertions, 4 deletions
diff --git a/community/searx/1831.patch b/community/searx/1831.patch
new file mode 100644
index 00000000000..a76e1c149c5
--- /dev/null
+++ b/community/searx/1831.patch
@@ -0,0 +1,27 @@
+Upstream: Yes, https://github.com/asciimoo/searx/pull/1831
+Reason: Fixes startup with py3-werkzeug 1.x
+From b8b13372c8fd3bfe978a1c724ab98b05348df054 Mon Sep 17 00:00:00 2001
+From: Nicolas Gelot <nicolas.gelot@e.email>
+Date: Thu, 6 Feb 2020 22:40:58 +0100
+Subject: [PATCH] Fix deprecated werkzeug import
+
+Close: #1830
+Signed-off-by: Nicolas Gelot <nicolas.gelot@e.email>
+---
+ requirements.txt | 2 +-
+ searx/webapp.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/searx/webapp.py b/searx/webapp.py
+index aadefe6b9..5ed9f1277 100644
+--- a/searx/webapp.py
++++ b/searx/webapp.py
+@@ -47,7 +47,7 @@
+ from html import escape
+ from datetime import datetime, timedelta
+ from time import time
+-from werkzeug.contrib.fixers import ProxyFix
++from werkzeug.middleware.proxy_fix import ProxyFix
+ from flask import (
+ Flask, request, render_template, url_for, Response, make_response,
+ redirect, send_from_directory
diff --git a/community/searx/APKBUILD b/community/searx/APKBUILD
index 3a8d9dbf88a..484648fc60d 100644
--- a/community/searx/APKBUILD
+++ b/community/searx/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=searx
pkgver=0.16.0
-pkgrel=0
+pkgrel=1
pkgdesc="Privacy-respecting metasearch engine"
url="https://asciimoo.github.io/searx/"
arch="noarch"
@@ -13,9 +13,12 @@ depends="python3 py3-certifi py3-babel py3-flask py3-flask-babel py3-idna
makedepends="py3-setuptools"
options="!check" # many missing deps, e.g. py3-splinter
source="https://github.com/asciimoo/searx/archive/v$pkgver/searx-$pkgver.tar.gz
- relax-dependencies.patch"
+ relax-dependencies.patch
+ 1831.patch"
prepare() {
+ default_prepare
+
# Searx only searches in $PWD for these by default
sed \
-e 's|static_path : ""|static_path : "/usr/lib/python3.8/site-packages/searx/static"|' \
@@ -39,4 +42,5 @@ package() {
}
sha512sums="4ea6d5a3cce8fb2b49d873f1ac16401ae7fb83672e5fe1e1b443b7b8563befeaa61e79e7383b85ff4360cbcf0a4bdf90e16cc7a16394f8b40c364d814404b03b searx-0.16.0.tar.gz
-c536e8ee7b9ca0ae142a51dec209dbd1f8890d16cc966d503448d059eee59acddf448a2899640af109b1531a934e280599af5603deb18b34a9924fd2a57dff6d relax-dependencies.patch"
+7ab2a9b3a14d878047f485667271e5b97102b2cc2b862cf07dc79bae4ddd0e08391aac89d7b1cdca90bfd77ae942c09e3bf4602015497b87530b3d84d06c9fe1 relax-dependencies.patch
+d85c9726882b841b4fc796616baaf2731b5d6d185c6df28bb296946700654cafb96c83242c4066630e56dbeeb54fc17750798049a9c73fe6c4514144b2fdd961 1831.patch"
diff --git a/community/searx/relax-dependencies.patch b/community/searx/relax-dependencies.patch
index 7ebb59b3d8c..3f95f7dbba0 100644
--- a/community/searx/relax-dependencies.patch
+++ b/community/searx/relax-dependencies.patch
@@ -17,7 +17,7 @@ index 6e4df37..8955910 100644
-requests[socks]==2.22.0
+certifi>2019.3.9
+babel>2.7.0<3
-+flask-babel>0.12.2<0.13
++flask-babel>=1.0.0<2
+flask>1.0.2<2
+idna>2.8<3
+jinja2>2.10.1<3