aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze <noel.kuntze@thermi.consulting>2021-08-07 00:27:36 +0200
committerAriadne Conill <ariadne@dereferenced.org>2021-08-07 01:18:35 +0000
commitcce4ee2c7a9b759c62b0ca2e1fef9ab7a9f90957 (patch)
treef829874520a601ff488ad8218d00630f57908132
parent75eb9e56022bd82a80cecf315b88d99298d7f1cd (diff)
testing/kopano-webapp-mdm: fix the custom unpack code
... to also extract into a new directory for other archive types other than tar.gz And also fix the source URL.
-rw-r--r--testing/kopano-webapp-mdm/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/testing/kopano-webapp-mdm/APKBUILD b/testing/kopano-webapp-mdm/APKBUILD
index 60a1156aabd..352582c62cd 100644
--- a/testing/kopano-webapp-mdm/APKBUILD
+++ b/testing/kopano-webapp-mdm/APKBUILD
@@ -2,7 +2,7 @@
pkgname=kopano-webapp-mdm
pkgdesc="mobile device management plugin for kopano-webapp"
pkgver=3.3.0
-pkgrel=1
+pkgrel=2
# ppc64le, mips64 and riscv64 blocked by libmdbx -> kopano-core -> kopano-webapp
arch="noarch !ppc64le !mips64 !riscv64"
url="https://stash.kopano.io/projects/KWA/repos/mobile-device-management/browse"
@@ -12,7 +12,7 @@ depends="kopano-webapp z-push php7-soap"
# kopano-core necessary for mapi php module
makedepends="apache-ant openjdk8 kopano-webapp-src"
source="
- kopano-webapp-mdm-$pkgver.zip::https://stash.kopano.io/rest/api/latest/projects/KWA/repos/mobile-device-management/archive?at=refs%2Ftags%2Fv$pkgver&format=tar.gz
+ kopano-webapp-mdm-$pkgver.zip::https://stash.kopano.io/rest/api/latest/projects/KWA/repos/mobile-device-management/archive?at=refs%2Ftags%2Fv$pkgver&format=zip
"
_pluginname="${pkgname//kopano-webapp-/}"
@@ -47,23 +47,23 @@ unpack() {
$gunzip -c "$s" | tar -C "$new_root_dir" -x ;;
*.tar.bz2)
msg "Unpacking $s..."
- tar -C "$srcdir" -jxf "$s" ;;
+ tar -C "$new_root_dir" -jxf "$s" ;;
*.tar.lz)
msg "Unpacking $s..."
- tar -C "$srcdir" --lzip -xf "$s" ;;
+ tar -C "$new_root_dir" --lzip -xf "$s" ;;
*.tar.lzma)
msg "Unpacking $s..."
- unlzma -T 0 -c "$s" | tar -C "$srcdir" -x ;;
+ unlzma -T 0 -c "$s" | tar -C "$new_root_dir" -x ;;
*.tar.xz)
msg "Unpacking $s..."
local threads_opt
if [ "$(readlink -f "$(command -v unxz)")" != "/bin/busybox" ]; then
threads_opt="--threads=0"
fi
- unxz $threads_opt -c "$s" | tar -C "$srcdir" -x ;;
+ unxz $threads_opt -c "$s" | tar -C "$new_root_dir" -x ;;
*.zip)
msg "Unpacking $s..."
- unzip -n -q "$s" -d "$srcdir" ;;
+ unzip -n -q "$s" -d "$new_root_dir" ;;
esac
done
}
@@ -110,5 +110,5 @@ package() {
fi
}
sha512sums="
-dff4544e0ec5f1798f8191a2e7fc5f173543c0b8df5acaefaaac137d5e0fa02075f3ea538c710c8242b895737510fa879ca5016a63c175cc581f75b4cf06a603 kopano-webapp-mdm-3.3.0.zip
+d64533242c16a5646fb0a9d2a05e089055129d8ec95b20adcd03a7f88e52203240ec36501c4212cb6d40e774e54886bc327f81b4adcbeaa1126a9529de9fbc55 kopano-webapp-mdm-3.3.0.zip
"