aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-27 22:41:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-27 23:41:03 -0300
commitcd5bfc939a6502c58479d0ba286cee0e3bd6bf0c (patch)
treeed5c85ae6c8a6ac5b0a0bde5a47c0d2135c97a23
parent564164e4d2008c9b3e961cd8c0d58c008dbf2afb (diff)
community/flawfinder: upgrade to 2.0.10
-rw-r--r--community/flawfinder/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/flawfinder/APKBUILD b/community/flawfinder/APKBUILD
index e4198e2ce1b..24777e27820 100644
--- a/community/flawfinder/APKBUILD
+++ b/community/flawfinder/APKBUILD
@@ -1,35 +1,30 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=flawfinder
-pkgver=2.0.8
+pkgver=2.0.10
pkgrel=0
pkgdesc="Examines C/C++ source code for security flaws"
url="http://www.dwheeler.com/flawfinder/"
arch="noarch"
license="GPL-2.0"
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-setuptools"
subpackages="$pkgname-doc"
-source="http://www.dwheeler.com/flawfinder/$pkgname-$pkgver.tar.gz
+source="http://www.dwheeler.com/flawfinder/flawfinder-$pkgver.tar.gz
use-python3.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
-
check() {
- cd "$builddir"
make check
}
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="9346c60808087ddf28f433067691c662beb0c36375903fdd0b4dbe3e53fe92b3893e38b13ecb0fe134586cf680fc554d33c92ff910dbd1cd4c3cbeab946038f4 flawfinder-2.0.8.tar.gz
+sha512sums="4bf24f4b84fc17d1cecda7686259efdd4d36afc267a315be147545518ba965929f3a58d13f534aec4c1816e55cfb854ec647d09e170bb5f5eccfb4dc3469acd0 flawfinder-2.0.10.tar.gz
aef3c9fc285255903e3b244bd76f99c7a7fe3c391f2d6a274ff7d1ea6dc38be82c9b537f3518c6cc600d5b3d5f60f1ed3b69aeaefc13246f9d908066273148ce use-python3.patch"