aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-07 21:36:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-07 21:45:48 +0000
commitcd6d900347ce1fd25a82ecba18a3f438d298e22a (patch)
tree0c41c38352982d486610adb41b439e160546900d
parentf3f48db58112213ee838129549ce029463970b46 (diff)
community/vlc: fix build on aarch64
Add the missing asm.S instead of patch that only makes sure the missing file is included in next release tarball. This is a temp worakround til next release.
-rw-r--r--community/vlc/APKBUILD2
-rw-r--r--community/vlc/fix-missing-asm.S-for-arm.patch69
2 files changed, 45 insertions, 26 deletions
diff --git a/community/vlc/APKBUILD b/community/vlc/APKBUILD
index dec0e29d7a7..51f9d8a4a09 100644
--- a/community/vlc/APKBUILD
+++ b/community/vlc/APKBUILD
@@ -333,5 +333,5 @@ e13e398b7bfd977f6e099bcb6cf8dc5cd5bad6dea3eff715881826246dc4329468846084aff2576d
22d80df599b8b65a5439cefbb7140af8e9530f326d54945da3769af65f37518b99ec2cc8647aafd2763324a0698280915afe043cc87e5720c4694881ed35bffa check-headless.patch
e214b407235cb3afb8bec93f20c9b42957b57e6fd3960679d3d4235e77762e03e64d03c01f00ef63d589e7c85aaad02ce6abbeeccd66b1867bc92451a5b5e9b0 disable-sub-autodetect-fuzzy-1-test.patch
c0107655249687655846a9547ca1a5670b9207443180600e7a149c69ffb96d7226787c19b018d4033db9b284c1a5faa8d7d42188ed40c3b8bb051256febf11c5 test-s390x.patch
-5d739a847708e4ed6f2fb06d81406a4980b63454628242794307663dc3f5af56dfdb44a7044d955bdda4df38b1c7880c510888c7eb50296e734aefec323fa96b fix-missing-asm.S-for-arm.patch
+cc625c382cc80cfae9c0dd6fe55a634e4ca4f0be0a83e8355721eae9447cb815af6a6000aeb6ae3667554d1670590fa2df6c635124bef85738d01609f65c9935 fix-missing-asm.S-for-arm.patch
b67b6e21e9d4027aef1006e6057f9ba8e65ce3895b08f7b911b1675cff9bc423f64ee2c187c584860e9e5d4635a30408a7781add9694d9bba753eac37f357406 vlc-libs.trigger"
diff --git a/community/vlc/fix-missing-asm.S-for-arm.patch b/community/vlc/fix-missing-asm.S-for-arm.patch
index 511650fb2e2..5b363fa1e9c 100644
--- a/community/vlc/fix-missing-asm.S-for-arm.patch
+++ b/community/vlc/fix-missing-asm.S-for-arm.patch
@@ -1,26 +1,45 @@
-From 29c4721b18ad422cc3cbb6aed9d321900dab0e51 Mon Sep 17 00:00:00 2001
-From: =?utf8?q?Martin=20Storsj=C3=B6?= <martin@martin.st>
-Date: Thu, 1 Mar 2018 22:20:45 +0200
-Subject: [PATCH] arm_neon: Include asm.S in distribution tarballs
-
-Signed-off-by: Thomas Guillem <thomas@gllm.fr>
-(cherry picked from commit 0d3878ef7488bab8bcb25b0f585143fea96e468f)
-Signed-off-by: Thomas Guillem <thomas@gllm.fr>
-
-Patch-Source: https://git.videolan.org/?p=vlc/vlc-3.0.git;a=commit;h=29c4721b18ad422cc3cbb6aed9d321900dab0e51
----
- modules/arm_neon/Makefile.am | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/modules/arm_neon/Makefile.am b/modules/arm_neon/Makefile.am
-index db81ec0b84..10f5c15d7c 100644
---- a/modules/arm_neon/Makefile.am
-+++ b/modules/arm_neon/Makefile.am
-@@ -28,3 +28,5 @@ neon_LTLIBRARIES = \
- libvolume_neon_plugin.la \
- libyuv_rgb_neon_plugin.la
- endif
+diff --git a/modules/arm_neon/asm.S b/modules/arm_neon/asm.S
+new file mode 100644
+index 0000000..728391e
+--- /dev/null
++++ b/modules/arm_neon/asm.S
+@@ -0,0 +1,39 @@
++/*
++ * Copyright (c) 2018 Janne Grunau <janne-libav@jannau.net>
++ *
++ * This program is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2.1 of the License, or (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU Lesser General Public
++ * License along with this program; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
++ */
+
-+EXTRA_DIST += arm_neon/asm.S
---
-2.11.0
++#ifdef __APPLE__
++# define EXTERN_ASM _
++#else
++# define EXTERN_ASM
++#endif
++
++#if defined(__APPLE__) || defined(_WIN32)
++# define HAVE_AS_ARCH_DIRECTIVE 0
++# define HAVE_AS_FPU_DIRECTIVE 0
++#else
++# define HAVE_AS_ARCH_DIRECTIVE 1
++# define HAVE_AS_FPU_DIRECTIVE 1
++#endif
++
++.macro function name
++ .globl EXTERN_ASM\name
++#ifdef __ELF__
++ .type EXTERN_ASM\name, %function
++#endif
++EXTERN_ASM\name:
++.endm