aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-13 23:38:35 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-16 16:47:57 +0000
commitcdb11c4e0c62ed0879baf7ad5a2e5f19ac894bbe (patch)
treec7ad0893a1ae8e792d97ca2d098a36a504195de9
parent8fb67a875ea8ed22da49c142cb6a2f00128ca225 (diff)
main/bzip2: upgrade to 1.0.8
-rw-r--r--main/bzip2/APKBUILD18
-rw-r--r--main/bzip2/bzip2-1.0.4-POSIX-shell.patch21
-rw-r--r--main/bzip2/bzip2-1.0.6-saneso.patch13
-rw-r--r--main/bzip2/saneso.patch23
4 files changed, 30 insertions, 45 deletions
diff --git a/main/bzip2/APKBUILD b/main/bzip2/APKBUILD
index ffacb3c6bb1..a28115a99d0 100644
--- a/main/bzip2/APKBUILD
+++ b/main/bzip2/APKBUILD
@@ -1,20 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bzip2
-pkgver=1.0.7
+pkgver=1.0.8
pkgrel=0
pkgdesc="A high-quality data compression program"
url="http://sources.redhat.com/bzip2"
arch="all"
-license="BSD"
-depends=""
-subpackages="$pkgname-dev $pkgname-doc libbz2"
+license="bzip2-1.0.6"
+subpackages="libbz2-static $pkgname-dev $pkgname-doc libbz2"
source="https://sourceware.org/pub/bzip2/bzip2-$pkgver.tar.gz
bzip2-1.0.4-makefile-CFLAGS.patch
- bzip2-1.0.6-saneso.patch
bzip2-1.0.4-man-links.patch
bzip2-1.0.2-progress.patch
bzip2-1.0.3-no-test.patch
- bzip2-1.0.4-POSIX-shell.patch
+ saneso.patch
"
# secfixes:
@@ -23,7 +21,6 @@ source="https://sourceware.org/pub/bzip2/bzip2-$pkgver.tar.gz
# 1.0.6-r5:
# - CVE-2016-3189
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare
@@ -40,7 +37,7 @@ prepare() {
bzip2.1 bzip2.txt Makefile-libbz2_so manual.*
}
-build () {
+build() {
cd "$builddir"
make -f Makefile-libbz2_so all
make all
@@ -65,10 +62,9 @@ libbz2() {
mv "$pkgdir"/usr/lib/*.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="e0e19b493e6b1f7beeb0eeb0be8a6358c24202173f28acb1e902a768835be9e24f2cb966452fbc90fc3e4e692532ce0c7e86d06aef2d52c0d2a9ac16e12ec8c8 bzip2-1.0.7.tar.gz
+sha512sums="083f5e675d73f3233c7930ebe20425a533feedeaaa9d8cc86831312a6581cefbe6ed0d08d2fa89be81082f2a5abdabca8b3c080bf97218a1bd59dc118a30b9f3 bzip2-1.0.8.tar.gz
58cc37430555520b6e35db2740e699cf37eacdd82989c21a222a593e36288710a0defb003662d4238235c12b3764bfc89cd646e6be9d0a08d54bd2c9baa6ad15 bzip2-1.0.4-makefile-CFLAGS.patch
-54da5648e33e0489c34a06efd444059558e2d3002c5c9bec65ea6443de18ad5b2c43c23b3fc1a04e385e20c23db074dc13633a2479489096fb9666e78ef102d2 bzip2-1.0.6-saneso.patch
2d9a306bc0f552a58916ebc702d32350a225103c487e070d2082121a54e07f1813d3228f43293cc80a4bee62053fd597294c99a1751b1685cd678f4e5c6a2fe7 bzip2-1.0.4-man-links.patch
b6810c73428f17245e0d7c2decd00c88986cd8ad1cfe4982defe34bdab808d53870ed92cb513b2d00c15301747ceb6ca958fb0e0458d0663b7d8f7c524f7ba4e bzip2-1.0.2-progress.patch
aefcafaaadc7f19b20fe023e0bd161127b9f32e0cd364621f6e5c03e95fb976e7e69e354ec46673a554392519532a3bfe56d982a5cde608c10e0b18c3847a030 bzip2-1.0.3-no-test.patch
-64ab461bf739c29615383750e7f260abb2d49df7eb23916940d512bd61fd9a37aaade4d8f6f94280c95fc781b8f92587ad4f3dda51e87dec7a92a7a6f8d8ae86 bzip2-1.0.4-POSIX-shell.patch"
+dd624110ce06426d2990ad1de96f5b6a2790c599030fb8848e26b64aa847cf956806f7a539fe61c6005d99bfc135920fc704f274862d2557ab1861adb7391d45 saneso.patch"
diff --git a/main/bzip2/bzip2-1.0.4-POSIX-shell.patch b/main/bzip2/bzip2-1.0.4-POSIX-shell.patch
deleted file mode 100644
index a5916eaff5e..00000000000
--- a/main/bzip2/bzip2-1.0.4-POSIX-shell.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-bzgrep uses !/bin/sh but then uses the bashism ${var//} so replace those
-with calls to sed so POSIX shells work
-
-http://bugs.gentoo.org/193365
-
---- ./bzgrep
-+++ ./bzgrep
-@@ -63,10 +63,9 @@
- bzip2 -cdfq "$i" | $grep $opt "$pat"
- r=$?
- else
-- j=${i//\\/\\\\}
-- j=${j//|/\\|}
-- j=${j//&/\\&}
-- j=`printf "%s" "$j" | tr '\n' ' '`
-+ # the backslashes here are doubled up as we have to escape each one for the
-+ # shell and then escape each one for the sed expression
-+ j=`printf "%s" "${i}" | sed -e 's:\\\\:\\\\\\\\:g' -e 's:[|]:\\\\|:g' -e 's:[&]:\\\\&:g' | tr '\n' ' '`
- bzip2 -cdfq "$i" | $grep $opt "$pat" | sed "s|^|${j}:|"
- r=$?
- fi
diff --git a/main/bzip2/bzip2-1.0.6-saneso.patch b/main/bzip2/bzip2-1.0.6-saneso.patch
deleted file mode 100644
index dc59f30147d..00000000000
--- a/main/bzip2/bzip2-1.0.6-saneso.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./Makefile-libbz2_so
-+++ ./Makefile-libbz2_so
-@@ -35,8 +35,8 @@
- bzlib.o
-
- all: $(OBJS)
-- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.7 $(OBJS)
-- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
-+ $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.7 $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
- rm -f libbz2.so.1.0
- ln -s libbz2.so.1.0.6 libbz2.so.1.0
-
diff --git a/main/bzip2/saneso.patch b/main/bzip2/saneso.patch
new file mode 100644
index 00000000000..529a0c20fc4
--- /dev/null
+++ b/main/bzip2/saneso.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile-libbz2_so b/Makefile-libbz2_so
+index fb0f230..2c95a3a 100644
+--- a/Makefile-libbz2_so
++++ b/Makefile-libbz2_so
+@@ -35,13 +35,13 @@ OBJS= blocksort.o \
+ bzlib.o
+
+ all: $(OBJS)
+- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.8 $(OBJS)
++ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.8 $(OBJS)
+ $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.8
+- rm -f libbz2.so.1.0
+- ln -s libbz2.so.1.0.8 libbz2.so.1.0
++ rm -f libbz2.so.1
++ ln -s libbz2.so.1.0.8 libbz2.so.1
+
+ clean:
+- rm -f $(OBJS) bzip2.o libbz2.so.1.0.8 libbz2.so.1.0 bzip2-shared
++ rm -f $(OBJS) bzip2.o libbz2.so.1.0.8 libbz2.so.1 bzip2-shared
+
+ blocksort.o: blocksort.c
+ $(CC) $(CFLAGS) -c blocksort.c
+