aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Weigt <juw@posteo.de>2021-07-26 20:22:05 +0300
committerAndy Postnikov <apostnikov@gmail.com>2021-08-28 06:51:55 +0000
commitce9114dee3676c0d0e6f3e8e2e032cfe75744dff (patch)
treef36d64ec96a28b057c5f0ea49555b0363ad373d8
parentd6c9ae1721abb1b11a184396b34f36d416b09e60 (diff)
testing/cyrus-sasl-xoauth2: new aport
-rw-r--r--testing/cyrus-sasl-xoauth2/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/cyrus-sasl-xoauth2/APKBUILD b/testing/cyrus-sasl-xoauth2/APKBUILD
new file mode 100644
index 00000000000..b245cd00748
--- /dev/null
+++ b/testing/cyrus-sasl-xoauth2/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Julian Weigt <juw@posteo.de>
+# Maintainer: Julian Weigt <juw@posteo.de>
+pkgname=cyrus-sasl-xoauth2
+pkgver=0.2
+pkgrel=0
+pkgdesc="XOAUTH2 mechanism plugin for cyrus-sasl"
+arch="all"
+url="https://github.com/moriyoshi/cyrus-sasl-xoauth2"
+license="MIT"
+makedepends="libtool autoconf automake cyrus-sasl-dev"
+subpackages="$pkgname-doc $pkgname-static"
+source="$pkgname-$pkgver.tar.gz::https://github.com/moriyoshi/cyrus-sasl-xoauth2/archive/refs/tags/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="
+c3a8fdc7c51a22df9fd8da5418a95e146b46c6865d4990dcf4053f18ca9ee9900b3b564e85cc8ec7bcde75966385b148e8320059b00f2f1374d4601c50e2c821 cyrus-sasl-xoauth2-0.2.tar.gz
+"