aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-26 15:48:16 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-26 15:55:14 +0100
commitced1a8b8b4b8d904ee0239c12b4d72699eb89493 (patch)
treeb61ffad949cd61a1f9c4ddb93c4e63d2608e47c3
parent82dc963dcd31781f17ba5f964a3ad3a9e5c3bab6 (diff)
main/wget: cleanup APKBUILD
-rw-r--r--main/wget/APKBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/main/wget/APKBUILD b/main/wget/APKBUILD
index 66d5cda4889..36dc613d920 100644
--- a/main/wget/APKBUILD
+++ b/main/wget/APKBUILD
@@ -9,13 +9,10 @@ pkgdesc="A network utility to retrieve files from the Web"
url="https://www.gnu.org/software/wget/wget.html"
arch="all"
license="GPL-3.0-or-later"
-depends=""
makedepends="libidn2-dev openssl-dev perl"
checkdepends="perl-http-daemon"
subpackages="$pkgname-doc"
-install=""
-source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://ftp.gnu.org/gnu/wget/wget-$pkgver.tar.gz"
# secfixes:
# 1.20.3-r0:
@@ -30,7 +27,6 @@ builddir="$srcdir/$pkgname-$pkgver"
# - CVE-2017-13090
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -45,15 +41,12 @@ build() {
}
check() {
- cd "$builddir"
-
# FIXME: We're not running top-level "check" to skip fuzz tests that
# are currently broken.
make -C tests check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/lib