aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrassy Boykinov <kboykinov@teamcentrixx.com>2023-09-18 15:25:03 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2023-09-18 20:36:20 +0000
commitceda1384ade4d6493639ae08ea0d1349fc85e9d1 (patch)
treef98cd12cee8166db50db83d5801f8fba47f9df34
parent38baf758ac61f707ba904b25823d4d4a651d6471 (diff)
testing/tecla: new aport
-rw-r--r--testing/tecla/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/tecla/APKBUILD b/testing/tecla/APKBUILD
new file mode 100644
index 00000000000..5c263c69a61
--- /dev/null
+++ b/testing/tecla/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Krassy Boykinov <kboykinov@teamcentrixx.com>
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
+pkgname=tecla
+pkgver=45.0
+pkgrel=0
+pkgdesc="Libadwaita keyboard layout viewer for the Gnome Desktop"
+url="https://gitlab.gnome.org/GNOME/tecla"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" # no tests
+makedepends="
+ gtk4.0-dev
+ libadwaita-dev
+ libxkbcommon-dev
+ meson
+ "
+subpackages="$pkgname-dev $pkgname-lang" # !! watch for -doc in future updates
+source="https://download.gnome.org/sources/tecla/${pkgver%.*}/tecla-$pkgver.tar.xz"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ # move pkgconfigs to /usr/lib/
+ mkdir -p "$pkgdir"/usr/lib/
+ mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib/
+
+}
+
+sha512sums="
+ae1f38870c14467ef7a868b60bc1a12ae1584fdd5e158d1cbf6f6639586225c7ffb8cfa00edeefc3930d4225a3865932e7fa724a5dff5f0ece3372363df289ce tecla-45.0.tar.xz
+"