aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2023-08-13 05:48:28 +0200
committerptrcnull <git@ptrcnull.me>2023-08-13 05:48:28 +0200
commitcf556704ada36492383cedb9224cc59b24d0c1b4 (patch)
tree25b4fba8802b821de5284d7b69d2862ea7eae7d7
parent9ea6aa8995be2488eea411c4342f791b61ebbabb (diff)
community/binaryen: actually fix build
-rw-r--r--community/binaryen/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/binaryen/APKBUILD b/community/binaryen/APKBUILD
index 7b127a2953b..e12cde878c6 100644
--- a/community/binaryen/APKBUILD
+++ b/community/binaryen/APKBUILD
@@ -28,7 +28,9 @@ builddir="$srcdir/$pkgname-version_$pkgver"
build() {
case "$CARCH" in
arm*|aarch64|riscv64)
- export CFLAGS="${CFLAGS/-fstack-clash-protection}" ;;
+ export CFLAGS="${CFLAGS/-fstack-clash-protection}"
+ export CXXFLAGS="${CFLAGS/-fstack-clash-protection}"
+ ;;
esac
CC=clang \