aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-11-21 10:24:33 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-11-21 23:55:18 +0000
commitcf7b64ec617cec691422007da0b30196cf3948a5 (patch)
tree7cd52ad9155bb21ef958b09cbcefffbadc1541b7
parent881a26bd89021b48d1e5db7200cb8353f9c2e2c9 (diff)
testing/py3-parver: new aport
Parse and manipulate PEP 440 version numbers https://github.com/RazerM/parver
-rw-r--r--testing/py3-parver/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-parver/APKBUILD b/testing/py3-parver/APKBUILD
new file mode 100644
index 00000000000..d4b2731c9c4
--- /dev/null
+++ b/testing/py3-parver/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=py3-parver
+_pkgname=parver
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Parse and manipulate PEP 440 version numbers"
+url="https://github.com/RazerM/parver"
+license="MIT"
+arch="noarch"
+depends="python3 py3-arpeggio"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-hypothesis py3-pretend"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/RazerM/parver/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD"/build/lib pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+}
+
+sha512sums="2ea7eb7be0c58657f5261d7b4729da6caaf2fac67db3fc3f36d29627bdbeba45f6ecb0e4bb251575b621908eb1ff5fa5ede5fc2ef0e041156dcc00548fd34360 parver-0.3.1.tar.gz"