aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2021-04-01 08:51:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2021-04-05 18:19:13 +0000
commitd1286735af4a7a1274593065fd39e6bc17aab89c (patch)
treeb0e0fde42054878a29383a9de22f90804b09b6c0
parenta62179858622457ab7d196f0b72520421d601863 (diff)
community/ceph: fix build
there might be more than one python site-packages installed. fixes commit 194bdb909ede (community/ceph: change more _pkg to amove)
-rw-r--r--community/ceph/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index 5a3eb5bf93e..8afca63f8ba 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=ceph
pkgver=15.2.10
-pkgrel=1
+pkgrel=2
pkgdesc="Ceph is a distributed object store and file system"
pkgusers="ceph"
pkggroups="ceph"
@@ -174,7 +174,10 @@ _ceph_gid=167
_prefix=/usr
_bindir=$_prefix/bin
_datadir=$_prefix/share
-_py3_sitelib="$(find /usr/lib -iname "site-packages")"
+
+_py3_sitelib() {
+ python3 -c "import site; print(site.getsitepackages()[0])"
+}
prepare() {
default_prepare
@@ -323,7 +326,7 @@ common() {
amove usr/share/ceph/*.ceph.com*
amove etc/ceph/rbdmap
- _pkg "$_py3_sitelib" ceph_argparse.py* ceph_daemon.py*
+ _pkg "$(_py3_sitelib)" ceph_argparse.py* ceph_daemon.py*
amove etc/udev/rules.d/50-rbd.rules
install -m 3770 -o $_ceph_uid -g $_ceph_gid -d \
@@ -442,8 +445,8 @@ ceph_volume() {
depends="$_ceph_volume_deps"
amove usr/sbin/ceph-volume
- amove "$_py3_sitelib"/ceph_volume
- amove "$_py3_sitelib"/ceph_volume-*
+ amove "$(_py3_sitelib)"/ceph_volume
+ amove "$(_py3_sitelib)"/ceph_volume-*
}
librados() {
@@ -457,7 +460,7 @@ _py3_rados() {
pkgdesc="Python libraries for the RADOS object store"
depends=
- amove "$_py3_sitelib"/rados*
+ amove "$(_py3_sitelib)"/rados*
}
libradosstriper() {
@@ -477,7 +480,7 @@ _py3_rbd() {
pkgdesc="Python libraries for the RADOS block device"
depends="py3-rados"
- amove "$_py3_sitelib"/rbd*
+ amove "$(_py3_sitelib)"/rbd*
}
libcephfs() {
@@ -490,8 +493,8 @@ _py3_cephfs() {
pkgdesc="Python libraries for Ceph distributed file system"
depends="py3-rados"
- amove "$_py3_sitelib"/cephfs*
- amove "$_py3_sitelib"/ceph_volume_client.py
+ amove "$(_py3_sitelib)"/cephfs*
+ amove "$(_py3_sitelib)"/ceph_volume_client.py
}
utils() {