aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2022-02-27 15:26:32 +0100
committerMichał Polański <michal@polanski.me>2022-02-27 15:26:32 +0100
commitd14ebd690f06dd606c7009eb18f69395e92dd2db (patch)
tree02fed419a5c203ece000b81fc4770ee195af655d
parentd442751b81497f111f948b56476f84da719764fa (diff)
community/py3-wsproto: upgrade to 1.1.0
-rw-r--r--community/py3-wsproto/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/py3-wsproto/APKBUILD b/community/py3-wsproto/APKBUILD
index 66dac4424d4..04ef1b341cd 100644
--- a/community/py3-wsproto/APKBUILD
+++ b/community/py3-wsproto/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-wsproto
-_pkgname=wsproto
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.1.0
+pkgrel=0
pkgdesc="Sans-IO WebSocket protocol implementation"
url="https://github.com/python-hyper/wsproto"
license="MIT"
@@ -11,19 +10,21 @@ arch="noarch"
depends="python3 py3-h11"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/python-hyper/wsproto/archive/$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+source="https://github.com/python-hyper/wsproto/archive/$pkgver/py3-wsproto-$pkgver.tar.gz"
+builddir="$srcdir/wsproto-$pkgver"
build() {
python3 setup.py build
}
check() {
- PYTHONPATH="$PWD"/build/lib pytest
+ PYTHONPATH="$PWD/build/lib" pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 setup.py install --root="$pkgdir" --skip-build
}
-sha512sums="f3aaff0bfcef68f0ccc8942331fd9f23a70efad1afb590d0e12547cd486c34d24944f41d98045ac7fc02a9a793823f55b3a9a0f8e3f9d779134f9013933c232b wsproto-1.0.0.tar.gz"
+sha512sums="
+b987e18f437cc69c742d9255d3fa3d88c836bef7aa286d68dc2dd802c3b17a655dfdd329258af23e4ee23b1faabc74604df8f584d249512723d89812815bd16d py3-wsproto-1.1.0.tar.gz
+"