aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Bredbury <brebs@sent.com>2020-10-22 12:10:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-10-22 12:02:48 +0000
commitd2ff197091aecdf0b239db39f2477bb6ea157383 (patch)
treef2d11fb950560a4bc6aca21520e59e217d914622
parent83b4beddd2ddc42a27a59da4170e6d00cb801f20 (diff)
testing/lout: prevent segfault in musl's catgets
$ gdb --args lout --help Program received signal SIGSEGV, Segmentation fault. 0x00007ffff7f88899 in catgets () from /lib/ld-musl-x86_64.so.1 Use suggested improvements from apkbuild-lint. Add maintainer.
-rw-r--r--testing/lout/APKBUILD12
-rw-r--r--testing/lout/lout-3.40-makefile.patch15
2 files changed, 18 insertions, 9 deletions
diff --git a/testing/lout/APKBUILD b/testing/lout/APKBUILD
index 242e81f9061..9d8ff30bd4b 100644
--- a/testing/lout/APKBUILD
+++ b/testing/lout/APKBUILD
@@ -1,6 +1,7 @@
+# Maintainer: Paul Bredbury <brebs@sent.com>
pkgname=lout
pkgver=3.40
-pkgrel=0
+pkgrel=1
pkgdesc="Lightweight typesetting and document formatting system"
url="https://savannah.nongnu.org/projects/lout"
arch="all"
@@ -8,14 +9,11 @@ license="GPL-3.0-or-later"
makedepends="zlib-dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc"
-source="https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+source="https://download.savannah.gnu.org/releases/lout/lout-$pkgver.tar.gz
lout-3.40-makefile.patch"
options="!check" # No test suite
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
make \
PREFIX="/usr" \
PDF_COMPRESSION=1 \
@@ -24,8 +22,6 @@ build() {
}
package() {
- cd "$builddir"
-
mkdir -p "$pkgdir/usr/bin" \
"$pkgdir/usr/share/doc/lout" \
"$pkgdir/usr/share/man/man1"
@@ -37,4 +33,4 @@ package() {
sha512sums="adffbb44b9328f0d64b1c8f08fe0217307b1cca870827ca54e0aaae5a2258f519e3e6f0adc715ba6d192dd731ab26c2cc86aa8611d991d5665503842e599c061 lout-3.40.tar.gz
-a4aa624c6134354e7d26bf70a618bc7f2ad4304eb2c551c124815e8153f0ee554b85ee3537c965e58c4de084716a4a4b7b1faf4ec5a9e58d682a92a52d69b0e6 lout-3.40-makefile.patch"
+de08770af3c7ba42a5e45414f0d2a5dc8f332dd17a123d1cad8baa5fe4a9040a79c03ae83e0abc628b698564e930a9212147e5ccd54fa3adab82bb16a4b370f8 lout-3.40-makefile.patch"
diff --git a/testing/lout/lout-3.40-makefile.patch b/testing/lout/lout-3.40-makefile.patch
index c9bcbfade4e..de82dd29556 100644
--- a/testing/lout/lout-3.40-makefile.patch
+++ b/testing/lout/lout-3.40-makefile.patch
@@ -1,6 +1,10 @@
+Use standard system file locations.
+Use distro's compilation options.
+Prevent musl getcats localization segfault.
+
diff -Naur a/makefile b/makefile
--- a/makefile 2012-02-08 07:28:03.000000000 +0000
-+++ b/makefile 2019-01-06 23:12:11.464068094 +0000
++++ b/makefile 2020-10-22 11:22:29.053732761 +0100
@@ -269,11 +269,11 @@
# DEBUGGING = 1
# TRACING = -g
@@ -17,6 +21,15 @@ diff -Naur a/makefile b/makefile
LIBFONT = font
LIBMAPS = maps
+@@ -285,7 +285,7 @@
+ CHARIN = 1
+ CHAROUT = 0
+
+-USELOC = 1
++USELOC = 0
+ LOC_FR = fr
+ LOC_DE = de
+
@@ -295,11 +295,9 @@
ZLIB =
ZLIBPATH =