aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-01 10:46:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-01 11:40:27 +0000
commitd30ed94d9cccb2596eccc4881bf94d8bfed8154e (patch)
tree998283e28c734ef5356df80b54ba15550afbefdc
parent5ba9cfc4cf0a1d570020faf2f8cb8e46a92ffaeb (diff)
community/qt5-qtdeclarative: upgrade to 5.10.1
-rw-r--r--community/qt5-qtdeclarative/APKBUILD10
-rw-r--r--community/qt5-qtdeclarative/qt-musl-stackbottom.patch17
2 files changed, 23 insertions, 4 deletions
diff --git a/community/qt5-qtdeclarative/APKBUILD b/community/qt5-qtdeclarative/APKBUILD
index 4761cdbb5a2..a7354480ddb 100644
--- a/community/qt5-qtdeclarative/APKBUILD
+++ b/community/qt5-qtdeclarative/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt5-qtdeclarative
-_pkgname=${pkgname/qt5-//}-opensource-src
-pkgver=5.9.3
+_pkgname=${pkgname/qt5-//}-everywhere-src
+pkgver=5.10.1
_ver=${pkgver/_p/-}
_ver=${_ver/_/-}
_ver=${_ver/beta0/beta}
@@ -19,7 +19,8 @@ case $pkgver in
*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
esac
-source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz"
+source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz
+ qt-musl-stackbottom.patch"
_qt5_prefix=/usr/lib/qt5
builddir="$srcdir"/$_pkgname-${_V%-*}
@@ -44,4 +45,5 @@ package() {
done
}
-sha512sums="933caf5848437cde45b4bbf0c70b6cafbc690657c651508b28138b2f90d2f823f4842bc709f4726e2c88d3913a92240b0dcd9248d83af0d06d7127b9a8211b24 qtdeclarative-opensource-src-5.9.3.tar.xz"
+sha512sums="b45b7c2232a3e7ddc8076066957f5c110a0ca9c815ee659f6e7656e85175a9ae56c52d6402d5437e4b60cd86508eb3c912ddd441e0be0ac9590ea263ad397048 qtdeclarative-everywhere-src-5.10.1.tar.xz
+235091cc1da51c31165a99932c95543d999c0f21b2c6b4318306b647662d420f88d7270ec21db7417fe9f8d87bfa3e5f01b6465c3542da024dd1623ef0a87681 qt-musl-stackbottom.patch"
diff --git a/community/qt5-qtdeclarative/qt-musl-stackbottom.patch b/community/qt5-qtdeclarative/qt-musl-stackbottom.patch
new file mode 100644
index 00000000000..fdfc19298ae
--- /dev/null
+++ b/community/qt5-qtdeclarative/qt-musl-stackbottom.patch
@@ -0,0 +1,17 @@
+For musl libc the stackBottom for the main thread is recalculated
+just as it is for Android. See: https://bugreports.qt.io/browse/QTBUG-44268
+
+--- qtdeclarative/src/qml/jsruntime/qv4engine.cpp 2016-02-26 10:34:34.000000000 +0100
++++ qtdeclarative/src/qml/jsruntime/qv4engine.cpp 2016-04-04 21:52:43.780823136 +0200
+@@ -94,6 +94,11 @@
+ #include <valgrind/memcheck.h>
+ #endif
+
++#if defined(Q_OS_LINUX) && !defined(__GLIBC__)
++#include <sys/syscall.h>
++#define gettid() syscall(SYS_gettid)
++#endif
++
+ QT_BEGIN_NAMESPACE
+
+ using namespace QV4;