aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-12-24 12:46:24 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-12-24 12:46:24 +0100
commitd3ca9303b871dd40a10faaa2983b7eaf523fcbb4 (patch)
treefb87f50bdc3c86b1dcaa9683050275897293ea40
parentf235fb476e60b8925fe4bf2b59da83f4d876e341 (diff)
community/libretro-mupen64plus: fix build with -fno-common
-rw-r--r--community/libretro-mupen64plus/APKBUILD6
-rw-r--r--community/libretro-mupen64plus/no-common.patch22
2 files changed, 26 insertions, 2 deletions
diff --git a/community/libretro-mupen64plus/APKBUILD b/community/libretro-mupen64plus/APKBUILD
index 6ddb5b4317c..35153076bb7 100644
--- a/community/libretro-mupen64plus/APKBUILD
+++ b/community/libretro-mupen64plus/APKBUILD
@@ -10,7 +10,8 @@ pkgdesc="libretro port of Mupen64 Plus with GLideN64"
license="GPL-2.0-or-later"
makedepends="mesa-dev zlib-dev libpng-dev nasm"
source="$pkgname-$pkgver.tar.gz::https://github.com/libretro/mupen64plus-libretro-nx/archive/$_commit.tar.gz
- musl-incompatibility.patch"
+ musl-incompatibility.patch
+ no-common.patch"
builddir="$srcdir/mupen64plus-libretro-nx-$_commit"
options="!check" # No tests
@@ -33,4 +34,5 @@ package() {
}
sha512sums="d0ad09dfbcfcfa5826857a30bac2c798f171abfa077064bc2089274388a3bdba03195b088dad1c932c9534a2e7f069f920535ce26f2b3d29b29ece5cbb2c5711 libretro-mupen64plus-0_git20200430.tar.gz
-8680a71cbecd1dfc30e1150d0cf258b20b928aa4eff341087a031c72459fc8a11415ebc5c8ff4fdd5b43915a6450f4dcad1aa9fb7ecbaceeed62aec3c45b5761 musl-incompatibility.patch"
+8680a71cbecd1dfc30e1150d0cf258b20b928aa4eff341087a031c72459fc8a11415ebc5c8ff4fdd5b43915a6450f4dcad1aa9fb7ecbaceeed62aec3c45b5761 musl-incompatibility.patch
+4992d2e7442c4d5dc09c0b9b9b9a7cb24577283342887efccb2521a6a97253e2f16ec64009d26d9cd03ebfc970ba69097a1b3aeca4c662d2bbdac49623554ad4 no-common.patch"
diff --git a/community/libretro-mupen64plus/no-common.patch b/community/libretro-mupen64plus/no-common.patch
new file mode 100644
index 00000000000..1d61eeb9ce8
--- /dev/null
+++ b/community/libretro-mupen64plus/no-common.patch
@@ -0,0 +1,22 @@
+Fix build with -fno-common, enabled by default since GCC 10.
+
+--- a/mupen64plus-core/src/device/r4300/idec.h
++++ b/mupen64plus-core/src/device/r4300/idec.h
+@@ -82,6 +82,6 @@
+
+ #define IDEC_U53(r4300, iw, u53, u5) (void*)(((char*)(r4300)) + idec_u53((iw), (u53), (u5)))
+
+-const char* g_r4300_opcodes[R4300_OPCODES_COUNT];
++extern const char* g_r4300_opcodes[R4300_OPCODES_COUNT];
+
+ #endif
+--- a/mupen64plus-core/src/main/workqueue.h
++++ b/mupen64plus-core/src/main/workqueue.h
+@@ -27,7 +27,6 @@
+
+ struct work_struct;
+
+-struct work_struct *work;
+ typedef void (*work_func_t)(struct work_struct *work);
+ struct work_struct {
+ work_func_t func;