aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-12 14:56:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-04-12 14:14:39 +0000
commitd4ceb5f4ea7abe5d55bbf3969eac3f683ddaf705 (patch)
treed5e51253219e7a0f7065c74aca1f72233caa3b38
parent0431fe40fcf635c590847c7158e4b1c758cfb1a7 (diff)
main/py3-pbr: add missing dependency
Before this change: $ dabuild sh $ sudo apk add py3-pbr >/dev/null && pbr --version Traceback (most recent call last): File "/usr/bin/pbr", line 6, in <module> from pbr.cmd.main import main File "/usr/lib/python3.8/site-packages/pbr/cmd/main.py", line 20, in <module> import pkg_resources ModuleNotFoundError: No module named 'pkg_resources' This change adds py3-setuptools as a runtime dependency because pkg_resources is imported by a file imported by /usr/bin/pbr: $ grep 'import pkg_resources' /usr/lib/python3.8/site-packages/pbr/cmd/main.py import pkg_resources pkg_resources is part of py3-setuptools: $ apk info -L py3-setuptools | grep pkg_resources/__init__.py usr/lib/python3.8/site-packages/pkg_resources/__init__.py After this change: $ dabuild sh $ sudo apk add py3-pbr >/dev/null && pbr --version 5.4.5
-rw-r--r--main/py3-pbr/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/py3-pbr/APKBUILD b/main/py3-pbr/APKBUILD
index 69acaa152ae..ac4b74e8f91 100644
--- a/main/py3-pbr/APKBUILD
+++ b/main/py3-pbr/APKBUILD
@@ -3,18 +3,17 @@
pkgname=py3-pbr
_pkgname=pbr
pkgver=5.4.5
-pkgrel=0
+pkgrel=1
pkgdesc="Python3 Build Reasonableness"
url="https://pypi.python.org/pypi/pbr"
arch="noarch"
license="Apache-2.0"
-depends="python3"
-makedepends="py3-setuptools"
+depends="python3 py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-replaces="py-pbr" # Backwarwds compatibility
-provides="py-pbr=$pkgver-r$pkgrel" # Backwarwds compatibility
+replaces="py-pbr" # Backwards compatibility
+provides="py-pbr=$pkgver-r$pkgrel" # Backwards compatibility
check() {
python3 setup.py check