aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-05 08:09:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:27 +0000
commitd6131c38042eed3e2cbfde9f348d99a47301e509 (patch)
treeb8bcee9dfb502e234c0ea302e8d5cc709bef59b5
parentc623939d0184c4fb6b2c40eb9b0b8fc48349ec29 (diff)
community/xmlsec: rebuild against libress-2.7
-rw-r--r--community/xmlsec/APKBUILD12
-rw-r--r--community/xmlsec/libressl-2.7.patch26
2 files changed, 32 insertions, 6 deletions
diff --git a/community/xmlsec/APKBUILD b/community/xmlsec/APKBUILD
index 62fa97f15b0..bb30b5c02e2 100644
--- a/community/xmlsec/APKBUILD
+++ b/community/xmlsec/APKBUILD
@@ -2,19 +2,18 @@
# Maintainer: Sander Maijers <S.N.Maijers+Alpine@gmail.com>
pkgname='xmlsec'
pkgver=1.2.25
-pkgrel=1
+pkgrel=2
pkgdesc="Provides a C based implementation for XML Signature Syntax and Processing and XML Encryption Syntax and Processing."
-url="https://github.com/lsh123/${pkgname}/"
+url="https://github.com/lsh123/xmlsec/"
arch="all"
license="MIT"
-depends=""
-depends_dev=
makedepends="${depends_dev} libxml2-dev libxslt-dev libressl-dev nss-dev
autoconf automake libtool"
install=
options="libtool"
subpackages="$pkgname-nss $pkgname-dev $pkgname-doc"
-source="${url}/archive/${pkgname}-${pkgver//./_}.tar.gz"
+source="https://github.com/lsh123/xmlsec/archive/xmlsec-${pkgver//./_}.tar.gz
+ libressl-2.7.patch"
builddir="${srcdir}/${pkgname}-${pkgname}-${pkgver//./_}"
prepare() {
@@ -59,4 +58,5 @@ nss() {
mv "$pkgdir"/usr/lib/libxmlsec1-$lib.so* "$subpkgdir"/usr/lib/
}
-sha512sums="3f05d76c70eecbcb38b466fc191a13ff692a39e36ab04c7d667f726b9e59e8896ce469e147f907fb044b154d0d5f00b89f6c0fc6d84a90b715efe6c80e0e123d xmlsec-1_2_25.tar.gz"
+sha512sums="3f05d76c70eecbcb38b466fc191a13ff692a39e36ab04c7d667f726b9e59e8896ce469e147f907fb044b154d0d5f00b89f6c0fc6d84a90b715efe6c80e0e123d xmlsec-1_2_25.tar.gz
+2ca8e2b844ba880d18bbd383c6ef5f4fdc650a3533daff3cc118e1f30e0929a98c5b1fca825274d810e14808a8fb3dd3557d4f944c118ae393fbd86a5f9d69bd libressl-2.7.patch"
diff --git a/community/xmlsec/libressl-2.7.patch b/community/xmlsec/libressl-2.7.patch
new file mode 100644
index 00000000000..9a8240204d7
--- /dev/null
+++ b/community/xmlsec/libressl-2.7.patch
@@ -0,0 +1,26 @@
+diff --git a/configure.ac b/configure.ac
+index 3278200..0fe3a76 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -489,7 +489,7 @@ if test "z$OPENSSL_FOUND" = "zyes" -a "z$OPENSSL_VERSION" = "z" ; then
+ if test "z$OPENSSL_VERSION" = "z" ; then
+ AC_EGREP_CPP(yes,[
+ #include <openssl/opensslv.h>
+- #if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER)
++ #if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL
+ yes
+ #endif
+ ],[
+diff --git a/include/xmlsec/openssl/crypto.h b/include/xmlsec/openssl/crypto.h
+index 96cc65b..353a2dd 100644
+--- a/include/xmlsec/openssl/crypto.h
++++ b/include/xmlsec/openssl/crypto.h
+@@ -43,7 +43,7 @@ XMLSEC_CRYPTO_EXPORT const xmlChar* xmlSecOpenSSLGetDefaultTrustedCertsFolde
+ * What version of the openssl API do we have? (also see configure.ac)
+ *
+ *******************************************************************/
+-#if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL
+ /* Libressl decided to take over OpenSSL version 2.0.0, likely will create
+ * issues down the road...
+ */