aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2021-01-25 12:33:39 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-01-25 17:53:59 +0000
commitd672cd48e5ae056771e2b60b58171e4a3a8a3b94 (patch)
treeeb062dd7ecaaa8bca93558c57a784389920441ee
parent18b1767747b6188c3ad6b9669c9463422704fb9e (diff)
testing/musescore: upgrade to 3.6
-rw-r--r--testing/musescore/APKBUILD8
-rw-r--r--testing/musescore/re-enable-qt5.15-support.patch23
2 files changed, 28 insertions, 3 deletions
diff --git a/testing/musescore/APKBUILD b/testing/musescore/APKBUILD
index 8e70ad79193..b89394227ff 100644
--- a/testing/musescore/APKBUILD
+++ b/testing/musescore/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
pkgname=musescore
-pkgver=3.5.2
+pkgver=3.6
pkgrel=0
pkgdesc="Create, play and print beautiful sheet music"
url="https://musescore.org/"
@@ -36,7 +36,8 @@ makedepends="
qtchooser
texlive-dev
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/musescore/MuseScore/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/musescore/MuseScore/archive/v$pkgver.tar.gz
+ re-enable-qt5.15-support.patch"
options="!check" # no testsuit provided
builddir="$srcdir"/MuseScore-$pkgver
@@ -48,4 +49,5 @@ package() {
DESTDIR="$pkgdir" make UPDATE_CACHE=FALSE -C build.release install
}
-sha512sums="4e98bebaa43abcb692969bd3272c64b6a8ff8e794c54ca8d4ed7dcb8059f4adbe498491f21b3b6d90e6495d4f44166747e1c1869617eba82af6db1aea6b06d38 musescore-3.5.2.tar.gz"
+sha512sums="7c2ee80239bb42581cabd92e47ac8654c65542297a58659a65543350784aed22ee90231ebd0f9c43140f67427690ade2e71fa4b6391d5fc9bb1fb14ba8790d19 musescore-3.6.tar.gz
+266f4c9072ed22f85f3ab95bcbd14546464a20dbd65b9db895fcafc2a067fb091d702341b9979278e0e4a1e17d402603d63e92eca5384e6be7d21cedadf332e7 re-enable-qt5.15-support.patch"
diff --git a/testing/musescore/re-enable-qt5.15-support.patch b/testing/musescore/re-enable-qt5.15-support.patch
new file mode 100644
index 00000000000..dd60928b1d1
--- /dev/null
+++ b/testing/musescore/re-enable-qt5.15-support.patch
@@ -0,0 +1,23 @@
+Re-enable Qt5.15 (due in 3.6.1)
+
+https://github.com/musescore/MuseScore/pull/7250/commits
+
+diff --git a/build/FindQt5.cmake b/build/FindQt5.cmake
+index 9ad7440..7c4f733 100644
+--- a/build/FindQt5.cmake
++++ b/build/FindQt5.cmake
+@@ -36,14 +36,6 @@ if (WIN32)
+ )
+ endif(WIN32)
+
+-# For Windows, because of these lines, for some unknown reason, the build of the .msi package fails.
+-if(NOT ${CMAKE_HOST_SYSTEM_NAME} MATCHES "Windows")
+- find_package(Qt5Core 5.15.0 QUIET)
+- if (Qt5Core_FOUND)
+- message(FATAL_ERROR "MuseScore 3 does not support Qt 5.15: 5.15.0 shows empty palettes panel, 5.15.1 and later crash when opening pre-3.6 scores due to QTBUG-77337")
+- endif()
+-endif()
+-
+ find_package(Qt5Core ${QT_MIN_VERSION} REQUIRED)
+
+ foreach(_component ${_components})