aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-11-09 09:44:57 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-11-09 09:47:01 +0000
commitd679c8df399a0ba9712b8d41ab00150496aeb35d (patch)
treec4a563292df31f32e42c15d5f7c84d7f86879021
parent8830a570f568bd5c5b0d66f3bd2a0ec002a4f0a7 (diff)
main/postgresql-pllua: fix s390x build, use proper lua binaries
-rw-r--r--main/postgresql-pllua/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/postgresql-pllua/APKBUILD b/main/postgresql-pllua/APKBUILD
index ca354695cfa..454105a81a4 100644
--- a/main/postgresql-pllua/APKBUILD
+++ b/main/postgresql-pllua/APKBUILD
@@ -13,8 +13,8 @@ license="MIT"
depends="postgresql"
# LuaJIT does not support s390x.
case "$CARCH" in
- s390x) _lua=lua5.3;;
- *) _lua=luajit; _luajit=luajit;;
+ s390x) _lua=lua5.3 _makeopts="LUAC=luac5.3 LUA=lua5.3";;
+ *) _lua=luajit; _makeopts="LUAJIT=luajit";;
esac
makedepends="postgresql-dev $_lua-dev"
options="!check" # tests require running PostgreSQL
@@ -27,7 +27,7 @@ builddir="$srcdir/$_pkgname-$_pkgver"
build() {
cd "$builddir"
- make ${_luajit:+"LUAJIT=$_luajit"} \
+ make $_makeopts \
LUA_INCDIR=$(pkgconf --variable=includedir $_lua) \
LUALIB=$(pkgconf --libs $_lua) \
USE_PGXS=1