aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Buchholz Göktürk <tomalok@gmail.com>2022-03-19 04:24:28 +0000
committerJake Buchholz Göktürk <tomalok@gmail.com>2022-03-19 04:24:28 +0000
commitd7360937b0e346ee93547a5cc4d1f637f48f3929 (patch)
treedaa8af1ec85e0d8b0114a965e8c198b256235c82
parent67345564d26dd55526901f148a7584792f89e8e6 (diff)
main/tiny-ec2-bootstrap: backport 1.4.3-r1
Alpine 3.12 doesn't have ifupdown-ng, which is required for tiny-cloud-network, so Alpine 3.12 cloud images need to stick with tiny-ec2-bootstrap for the next couple months until it's EOL'd. tiny-ec2-bootstrap 1.4.3-r1 fixes a problem with locking the root account's password.
-rw-r--r--main/tiny-ec2-bootstrap/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/main/tiny-ec2-bootstrap/APKBUILD b/main/tiny-ec2-bootstrap/APKBUILD
index 9e85c2af163..3059264b11d 100644
--- a/main/tiny-ec2-bootstrap/APKBUILD
+++ b/main/tiny-ec2-bootstrap/APKBUILD
@@ -1,19 +1,22 @@
+# Contributor: Jake Buchholz Göktürk <tomalok@gmail.com>
# Contributor: Mike Crute <mike@crute.us>
# Maintainer: Mike Crute <mike@crute.us>
pkgname=tiny-ec2-bootstrap
pkgver=1.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="A tiny EC2 instance bootstrapper that uses instance metadata"
-url="https://github.com/mcrute/tiny-ec2-bootstrap"
+url="https://gitlab.alpinelinux.org/alpine/cloud/tiny-ec2-bootstrap"
arch="noarch"
license="MIT"
options="!check" # no tests provided
-depends="openrc e2fsprogs-extra"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mcrute/tiny-ec2-bootstrap/archive/release-$pkgver.tar.gz"
+depends="openrc e2fsprogs-extra sfdisk util-linux"
+source="https://gitlab.alpinelinux.org/alpine/cloud/tiny-ec2-bootstrap/-/archive/release-$pkgver/tiny-ec2-bootstrap-release-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-release-$pkgver"
package() {
make PREFIX=$pkgdir install
}
-sha512sums="6b15eaae722975b5f9deb6650cfd2319a37cab24084c3638ee3264e7784637cadfda863777909fc2cb09f1c27755082591b645342da697be040687da7a9936f3 tiny-ec2-bootstrap-1.4.3.tar.gz"
+sha512sums="
+6b15eaae722975b5f9deb6650cfd2319a37cab24084c3638ee3264e7784637cadfda863777909fc2cb09f1c27755082591b645342da697be040687da7a9936f3 tiny-ec2-bootstrap-release-1.4.3.tar.gz
+"