aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-08-20 18:17:18 +0000
committerpsykose <alice@ayaya.dev>2022-08-20 20:17:18 +0200
commitd847be711d554848cfef3a1cf3c3d17e02b7197d (patch)
treedcc9c9d832a92546da802d666f5a566fe6ad0652
parent75d6cf664c5860b7136e1117608196ffc98ba0ab (diff)
community/ghc: disable check on aarch64
-rw-r--r--community/ghc/APKBUILD9
-rw-r--r--community/ghc/skip-tests.patch27
2 files changed, 19 insertions, 17 deletions
diff --git a/community/ghc/APKBUILD b/community/ghc/APKBUILD
index b6e0ca70df1..71a575ee42e 100644
--- a/community/ghc/APKBUILD
+++ b/community/ghc/APKBUILD
@@ -55,6 +55,13 @@ source="https://downloads.haskell.org/~ghc/$_urlprefix/$_pkgprefix-src.tar.xz
llvm14.patch
"
+case "$CARCH" in
+aarch64)
+ # 116 more failures
+ options="$options !check"
+ ;;
+esac
+
prepare() {
default_prepare
@@ -163,7 +170,7 @@ b2375500ae837d74af8085d099899b5a7a589c59bdcc033ca0bd6e00f33c4f8d90b481e0c7c3de11
4133c70bb46b7aba9b8eba87cdbd58d802584e5e8ffb01450c80bb4607e6e90a45a437ea142aa8a8cb199dc6f46e769437c3c47769976093490de71161a3943d 0005-buildpath-abi-stability.patch
ac2ad793b4d33ea890e236820af4cd10996b47d0f4249c825b31450145cb8195c2be62f2d7942cc3bf564f768dca187379196b251f4b37ed326ed2a0a5f59e8a 0001-testsuite-unset-MAKEFLAGS-when-calling-python.patch
b71bb7945c6cae3ea324ff1de9576b883f0e63169fbe50d781acc0f4fb694387c43bf7aa1bd1cca236613ff202dd503c4577dc06368614752affdc54a5c62101 0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch
-3c46fab45a484a96f2166b4331a00708792b8107b697e4ec0cb3d51bcc6b7305142e380e6f1ed3de9f8359482d0392c7639396366afed2dea440087109367d4f skip-tests.patch
+00202b0248b738327058539354da3208c88f7f7bb8aa545ee00a7549c725f10bec2a5499a4277ee61526e67871c3ea95f7f0b5d51c5d66b43fb88ec9484f8708 skip-tests.patch
c3bc4f872d3903c4446167df1a88ec54cdd712c4b0ea0b0c35487e9b7e5bd7124da0688d1d5fbf26cad932e841f0299ada304e2300c25e01ffe3de10b74e78c1 tests-use-iterable-from-collections-abc.patch
2e11a83844c4a9f895f60af9f014cd1989eeb4efb6a96576d62aa0abe55792eaf4f4963c05599900edb7ad371745923a4022119a802b3f8905d2c8fcb46697af llvm14.patch
"
diff --git a/community/ghc/skip-tests.patch b/community/ghc/skip-tests.patch
index 493e580550d..a5a137d73ab 100644
--- a/community/ghc/skip-tests.patch
+++ b/community/ghc/skip-tests.patch
@@ -1,48 +1,43 @@
diff --git a/libraries/base/tests/IO/all.T b/libraries/base/tests/IO/all.T
-index 9475183..ba662de 100644
+index 9475183b..da8beee9 100644
--- a/libraries/base/tests/IO/all.T
+++ b/libraries/base/tests/IO/all.T
-@@ -119,7 +119,9 @@ test('encoding001', [], compile_and_run, [''])
+@@ -119,7 +119,11 @@ test('encoding001', [], compile_and_run, [''])
test('encoding002', normal, compile_and_run, [''])
test('encoding003', normal, compile_and_run, [''])
-test('encoding004', extra_files(['encoded-data/']), compile_and_run, [''])
+test('encoding004',
-+ [when(platform('x86_64-alpine-linux'), skip), extra_files(['encoded-data/'])],
++ [when(platform('x86_64-alpine-linux'), skip),
++ when(platform('aarch64-alpine-linux'), skip),
++ extra_files(['encoded-data/'])],
+ compile_and_run, [''])
test('encoding005', normal, compile_and_run, [''])
test('environment001', [], makefile_test, ['environment001-test'])
diff --git a/testsuite/tests/ghci/linking/all.T b/testsuite/tests/ghci/linking/all.T
-index 29a3142..0fd3be9 100644
+index e86e1ea3..85f6112a 100644
--- a/testsuite/tests/ghci/linking/all.T
+++ b/testsuite/tests/ghci/linking/all.T
-@@ -7,6 +7,7 @@ test('ghcilink001',
+@@ -7,6 +7,8 @@ test('ghcilink001',
test('ghcilink002', [extra_files(['TestLink.hs', 'f.c']),
when(unregisterised(), fragile(16085)),
+ when(platform('x86_64-alpine-linux'), skip),
++ when(platform('aarch64-alpine-linux'), skip),
unless(doing_ghci, skip)],
makefile_test, ['ghcilink002'])
diff --git a/testsuite/tests/ghci/linking/dyn/all.T b/testsuite/tests/ghci/linking/dyn/all.T
-index 127c970..62b053c 100644
+index 127c9707..7c36880c 100644
--- a/testsuite/tests/ghci/linking/dyn/all.T
+++ b/testsuite/tests/ghci/linking/dyn/all.T
-@@ -25,6 +25,7 @@ test('T10955dyn', [extra_files(['A.c', 'B.c'])], makefile_test, ['compile_libAB_
+@@ -25,6 +25,8 @@ test('T10955dyn', [extra_files(['A.c', 'B.c'])], makefile_test, ['compile_libAB_
test('T10458',
[extra_files(['A.c']),
unless(doing_ghci, skip),
+ when(platform('x86_64-alpine-linux'), skip),
++ when(platform('aarch64-alpine-linux'), skip),
pre_cmd('$MAKE -s --no-print-directory compile_libT10458'),
extra_hc_opts('-L"$PWD/T10458dir" -lAS')],
ghci_script, ['T10458.script'])
---- a/testsuite/tests/rts/linker/all.T
-+++ b/testsuite/tests/rts/linker/all.T
- [extra_files(['LinkerUnload.hs', 'Test.hs']),
- req_rts_linker,
- unless(have_dynamic(), skip),
-+ when(platform('x86_64-alpine-linux'), skip),
- when(opsys('darwin') or opsys('mingw32'), skip)],
- makefile_test, ['linker_unload_native'])
-