aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-08-09 13:34:56 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-08-09 13:34:56 +0000
commitd88670fe913cbd0ea60de9d0e3b847928ca6a118 (patch)
tree5e270c5e2eb8c13fd48cbd6cb8227a3f633ade97
parent750a4e44fb9312dbddd2cbe258e19bf6818b5cbd (diff)
community/py3-cx_freeze: fix permissions
Files in the package are set to 0700 and directories to 2700. These permissions end up in the package, which prevents any user other than root to read these files. Fix this by setting all files to 0644 and all directories to 0755. This does not interfere with any executable scripts in this package, because they still end up with executable permissions in the package.
-rw-r--r--community/py3-cx_freeze/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/community/py3-cx_freeze/APKBUILD b/community/py3-cx_freeze/APKBUILD
index d370687142b..1108959d416 100644
--- a/community/py3-cx_freeze/APKBUILD
+++ b/community/py3-cx_freeze/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-cx_freeze
_pkgname=cx_Freeze
pkgver=6.2
-pkgrel=0
+pkgrel=1
pkgdesc="Set of utilities for freezing Python scripts into executables"
url="http://cx-freeze.sourceforge.net/"
arch="all"
@@ -15,6 +15,14 @@ builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-cx_freeze" # Backwards compatibility
provides="py-cx_freeze=$pkgver-r$pkgrel" # Backwards compatibility
+prepare() {
+ default_prepare
+
+ # fix permissions, which are 0700 for files and 2700 for directories
+ find "$builddir" -type f -exec chmod 0644 {} \;
+ find "$builddir" -type d -exec chmod 0755 {} \;
+}
+
check() {
python3 setup.py check
}