aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-11-24 07:30:46 +0000
committerpsykose <alice@ayaya.dev>2022-11-24 08:30:46 +0100
commitd9b166f3752b7bab46f8449220edd82b85296f71 (patch)
tree4890cc95bda0cb57dd33c1dd1bc117d3aaab20af
parentf602a0d11563ec44ebee0fd12e78a4cd5a6fc14d (diff)
testing/subliminal: fix build
-rw-r--r--testing/subliminal/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/subliminal/APKBUILD b/testing/subliminal/APKBUILD
index f153c344a1b..d1663391233 100644
--- a/testing/subliminal/APKBUILD
+++ b/testing/subliminal/APKBUILD
@@ -24,15 +24,17 @@ depends="python3
py3-tz
"
makedepends="py3-setuptools"
-checkdepends="python3-dev py3-pytest py3-pytest-runner libarchive-tools"
+checkdepends="python3-dev py3-pytest py3-pytest-runner libarchive-tools py3-vcrpy py3-sympy"
source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
tests.patch legendastv.patch"
+options="!check" # missing simpy
build() {
python3 setup.py build
}
check() {
+ PYTHONPATH=. \
pytest -k 'not test_save_subtitles_single_directory_encoding'
}