aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-03-12 19:08:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-13 11:53:01 +0000
commitda7560bb0730a6220ae2e9bcbed2bccde51f6919 (patch)
tree47205a0183956efa3fb80a0bf5af62458de674ef
parent4058f0174dacdf6ac92c468e478c7b2e43f28f5a (diff)
testing/ocaml-camomile: workaround ppc64le segfault while building
-rw-r--r--testing/ocaml-camomile/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/ocaml-camomile/APKBUILD b/testing/ocaml-camomile/APKBUILD
index d47bfb6b189..d8f03279a1e 100644
--- a/testing/ocaml-camomile/APKBUILD
+++ b/testing/ocaml-camomile/APKBUILD
@@ -3,12 +3,12 @@
pkgname=ocaml-camomile
_pkgname=camomile
pkgver=0.8.7
-pkgrel=1
+pkgrel=2
pkgdesc="A Unicode library for OCaml"
url="https://github.com/yoriyuki/Camomile"
# x86, armhf, s390x: limited by ocaml aport
-# ppc64le: https://github.com/yoriyuki/Camomile/issues/39
-arch="all !x86 !armhf !s390x !ppc64le"
+# ppc64le: https://github.com/yoriyuki/Camomile/issues/39. Workaround by setting hard and soft stack limits
+arch="all !x86 !armhf !s390x"
license="LGPL-2.0-or-later"
depends="$pkgname-data=$pkgver-r$pkgrel ocaml-runtime"
makedepends="dune ocaml ocaml-compiler-libs ocaml-cppo ocaml-findlib opam"
@@ -17,6 +17,10 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/yoriyuki/$_pkgname/archive/r
builddir="$srcdir/Camomile-rel-$pkgver"
build() {
+ if [ "$CARCH" = "ppc64le" ]; then
+ ulimit -Hs unlimited
+ ulimit -Ss 65536
+ fi
cd "$builddir"
jbuilder build @install
}